summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-28 09:36:26 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-28 11:22:26 +0100
commitaf4c404447a6638d24a66743baadf4eec7543907 (patch)
tree987acee8d03caf1d91e4b28e1d3996d788d6187c /net-misc/whatportis/whatportis-0.3.ebuild
parentnet-misc/whatportis: Set license (diff)
downloadgentoo-af4c404447a6638d24a66743baadf4eec7543907.tar.gz
gentoo-af4c404447a6638d24a66743baadf4eec7543907.tar.bz2
gentoo-af4c404447a6638d24a66743baadf4eec7543907.zip
net-misc/whatportis: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-misc/whatportis/whatportis-0.3.ebuild')
-rw-r--r--net-misc/whatportis/whatportis-0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/whatportis/whatportis-0.3.ebuild b/net-misc/whatportis/whatportis-0.3.ebuild
new file mode 100644
index 000000000000..2b25ee8c3f3e
--- /dev/null
+++ b/net-misc/whatportis/whatportis-0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A command to search port names and numbers"
+HOMEPAGE="http://github.com/ncrocfer/whatportis http://pypi.python.org/pypi/whatportis"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/click-6.2[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" test_${PN}.py || die
+}