summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:31:58 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:47:03 +0200
commit13eb61d316b00795d68f15c975e3a9ed03d9d3be (patch)
tree422375868c586e114fcce2b99004a6a6c75d30d1 /net-misc/x2goclient
parentx11-plugins/wmbiff: 0.4.34 bump (diff)
downloadgentoo-13eb61d316b00795d68f15c975e3a9ed03d9d3be.tar.gz
gentoo-13eb61d316b00795d68f15c975e3a9ed03d9d3be.tar.bz2
gentoo-13eb61d316b00795d68f15c975e3a9ed03d9d3be.zip
net-misc/x2goclient: support 17.1 profiles
Closes: https://bugs.gentoo.org/689280 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/x2goclient')
-rw-r--r--net-misc/x2goclient/files/x2goclient-4.1.2.1-gentoo-17.1.patch14
-rw-r--r--net-misc/x2goclient/x2goclient-4.1.2.1-r1.ebuild75
2 files changed, 89 insertions, 0 deletions
diff --git a/net-misc/x2goclient/files/x2goclient-4.1.2.1-gentoo-17.1.patch b/net-misc/x2goclient/files/x2goclient-4.1.2.1-gentoo-17.1.patch
new file mode 100644
index 000000000000..b9a63264be99
--- /dev/null
+++ b/net-misc/x2goclient/files/x2goclient-4.1.2.1-gentoo-17.1.patch
@@ -0,0 +1,14 @@
+X-Git-Url: https://code.x2go.org/gitweb?p=x2goclient.git;a=blobdiff_plain;f=src%2Fonmainwindow.cpp;h=cd97e6c7f28a6ab4e9495f7a9ba4b447f2b47a2f;hp=cb6bb72918cdc1d54f57cbf0b426adb03a6f4dc8;hb=567223f;hpb=fc5c93518b9023e2499a945740cd6559233ed301
+
+diff --git a/src/onmainwindow.cpp b/src/onmainwindow.cpp
+index cb6bb72..cd97e6c 100644
+--- a/src/onmainwindow.cpp
++++ b/src/onmainwindow.cpp
+@@ -10754,6 +10754,7 @@ void ONMainWindow::generateEtcFiles()
+ << "/usr/libexec/openssh" /* Fedora, CentOS, hopefully also RHEL */
+ << "/usr/lib/ssh" /* Mageia, OpenSUSE, SLE{S,D} < 12 x86, SLE{S,D} 12, Arch */
+ << "/usr/lib64/ssh" /* SLE{S,D} < 12 x86_64 */
++ << "/usr/lib64/misc" /* Gentoo *64 with 17.1 profile - has no lib compat-symlink. */
+ << "/usr/lib/misc" /* Gentoo */
+ << "/run/current-system/sw/bin" /* NixOS */
+ << "/usr/libexec"; /* Slackware, OS X */
diff --git a/net-misc/x2goclient/x2goclient-4.1.2.1-r1.ebuild b/net-misc/x2goclient/x2goclient-4.1.2.1-r1.ebuild
new file mode 100644
index 000000000000..953c984a775f
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.1.2.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils qmake-utils
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+COMMON_DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=net-libs/libssh-0.7.5-r2
+ net-print/cups
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD="${WORKDIR}"/${P}.client_build
+PLUGIN_BUILD="${WORKDIR}"/${P}.plugin_build
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt511.patch"
+ "${FILESDIR}/${P}-gentoo-17.1.patch"
+)
+
+src_prepare() {
+ default
+
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i src/x2goclientconfig.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 "${S}"/x2goclient.pro
+}
+
+src_install() {
+ dobin ${PN}
+
+ local size
+ for size in 16 32 48 64 128 ; do
+ doicon -s ${size} res/img/icons/${size}x${size}/${PN}.png
+ done
+ newicon -s scalable res/img/icons/hildon/${PN}_hildon.svg ${PN}.svg
+
+ insinto /usr/share/pixmaps
+ doins res/img/icons/${PN}.xpm
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}