summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-08-12 06:40:05 +0200
committerJeroen Roovers <jer@gentoo.org>2015-08-12 06:40:05 +0200
commit31fc1eb3bcdc3680bc5b3a5a16c77e075558d21b (patch)
tree858f2d767436536bfc6d4c673ee756b8dccc7f97 /net-misc/youtube-dl
parentOld. (diff)
downloadgentoo-31fc1eb3bcdc3680bc5b3a5a16c77e075558d21b.tar.gz
gentoo-31fc1eb3bcdc3680bc5b3a5a16c77e075558d21b.tar.bz2
gentoo-31fc1eb3bcdc3680bc5b3a5a16c77e075558d21b.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.20
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2015.08.09.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 53bc85bfbce5..136b4b4d7e44 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163ca74660ed443781b6e69b4e06d36d7bf59 SHA512 6b2c85cfa222a31f3462aab583fa98bb92544cd5fb0d395ca0b69a26c24ab174870d02264e058281f09305752d50aa5a06d0d747205499a530b275e3194fc6f9 WHIRLPOOL 391e06ea261f92e03a0b38618307f1c9d53a2dfb9f2062fe0cd3ded1ea0c411033a17ded581616032c74a9e4fb398a57e565bf847196a23a9f89433f861362ae
DIST youtube-dl-2015.07.28.tar.gz 1671847 SHA256 61c3acea56cb6127c092fed37ce77c64f14b501faceab54496412d3479685c56 SHA512 d1df40ece3a384859ee25419c7caafb37d55fc504920ba638d40ea4971a97e5dc70a2d03be30fadef5ff24df9f55d471095d707795d7951ba3ebe76735d1a9be WHIRLPOOL 49daef34e160a731d5f37c92dca038c86e3ada1d9f3f8468c97e7e164b575bf022bb04636e8967bb7fe723fbbb51b68aa3db25563873ac626f85053f5b4a1444
DIST youtube-dl-2015.08.06.1.tar.gz 1684397 SHA256 efd25b9827851a5b8f7108437ea4d84f778702e59fcf85e37e9e0933b8a5c908 SHA512 4e7c35f0f903092c218439e2e9437b7af8c18a26a5d918d0ec086749d15d485ec781ac35cfd25498c4e99bccafdaf7283ea51fa6538109b4798ac3a32a5fd106 WHIRLPOOL 169e42c89d46da2dda59af4f92fa60eb7c1132eceedbdeeb6d139676997d61d8fb858a1d689dc23657f085457a678ddbabe8b816567f7ac11bdf8f8bc8426e60
+DIST youtube-dl-2015.08.09.tar.gz 1694525 SHA256 01bd26ceb7bfde7bef2528666807241354087cf01b198b3d48623ee5e3c4b746 SHA512 16e805081e4ca090c577120dea81b180cc96ff86bdf2e0cd0e76cb2857babba307f375a3605f184af76b7a359c1d15d867c79585d2918c537aa6a8450aaa5dd8 WHIRLPOOL 5e41826a3b2edc3b0949a35fe7671e93490760480deb0454d04578be2fe07f12be391b7057ccf84fc621c93e339bf6bb03e43e1c09b67de553eed5262418483e
diff --git a/net-misc/youtube-dl/youtube-dl-2015.08.09.ebuild b/net-misc/youtube-dl/youtube-dl-2015.08.09.ebuild
new file mode 100644
index 000000000000..f78acdd93f6f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2015.08.09.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="http://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink drtuber eporner eroprofile extremetube
+ fourtube foxgay goshgay hellporno hentaistigma hornbunny keezmovies
+ mofosex motherless porn91 pornhd pornotube pornovoisines pornoxo
+ redtube sexykarma sexu sunporno slutload spankbang spankwire thisav
+ trutube tube8 vporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}