summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-16 17:42:52 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-16 17:42:52 +0100
commit878aa60eee479b4634e4422ad9ffde136516c53b (patch)
treef25e401f175986b3e8c34b22d40ee84d9838827e /net-misc/youtube-dl
parentnet-misc/iperf: Version bump. (diff)
downloadgentoo-878aa60eee479b4634e4422ad9ffde136516c53b.tar.gz
gentoo-878aa60eee479b4634e4422ad9ffde136516c53b.tar.bz2
gentoo-878aa60eee479b4634e4422ad9ffde136516c53b.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.02.13.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 1e8986689b4a..efc747ea4c08 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.02.01.tar.gz 1931170 SHA256 cac97ffda989b5783b7b05dd04cdb9f602089163d4c0dbeb55fc749899422613 SHA512 04db834328056402b2a91e9e244fa74abb4a7782fcea489c9ae7b6669f96ebc2d13cff576b02ccbbdfe3d6914c90ebc2b728334422a0ae0e454b1e03dd9db2b1 WHIRLPOOL 04c731813b50770864504f13b18cf493639975a27de0e10faad20e90f8d800228e4792924c5a7ca1b0e99df5729422e9a6209253159af63f5ab07e8118c87af2
DIST youtube-dl-2016.02.10.tar.gz 1943121 SHA256 386cfc2128eebbedf2c4ffdb41537aede509436cdb6b6ef596da4eece376d023 SHA512 1242fd72705726334b1651a55d6406065145ace16d8f23d4cc25f729a2efc5db098a5de1beba68cf924e51bab6fa70745ae958a539421c168b3fd4c636076614 WHIRLPOOL 5813233d1955099f2a6b0fc897e7a06881f04a79cbf4de5ec54ed2c94dc24ea1f52a8aec9c06a1d67c054875d9bdcd7ce101f38392a8b4e428199530360200dc
+DIST youtube-dl-2016.02.13.tar.gz 1951048 SHA256 8bb5cb62aad23fd3b049d9ffac76af6d76af8c18d68da3a3b9f602adaca1d534 SHA512 5f453835e2829b74a1dce141180cfab33cb8e3ad8404f0b866495c7421d3e938a3ce374bcc7f4b11c52ac37e26a6e34692e7c147824f447e5f826253d32b1a47 WHIRLPOOL 132c175650f47fdf4d0b17a1c5d36b5dd1a183594193c328eb94eda58a6da6819689bb7fe732606e9c5f901ab3896a0a712f534cb29cf4355a925e9290441dc0
diff --git a/net-misc/youtube-dl/youtube-dl-2016.02.13.ebuild b/net-misc/youtube-dl/youtube-dl-2016.02.13.ebuild
new file mode 100644
index 000000000000..5db7401e49ee
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.02.13.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink chaturbate drtuber eporner eroprofile
+ extremetube fourtube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies mofosex motherless porn91 pornhd pornotube
+ pornovoisines pornoxo redtube sexykarma sexu sunporno slutload
+ spankbang spankwire thisav trutube tube8 vporn xbef xnxx xtube
+ xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}