summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-30 08:30:54 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-30 08:33:54 +0200
commit90fad8fcf30df13a3f080febee448ba4d64c00cf (patch)
treed3ca3a795598c14b23511a625a6fc98c90e90f2e /net-misc/youtube-dl
parentnet-misc/youtube-dl: Stable (diff)
downloadgentoo-90fad8fcf30df13a3f080febee448ba4d64c00cf.tar.gz
gentoo-90fad8fcf30df13a3f080febee448ba4d64c00cf.tar.bz2
gentoo-90fad8fcf30df13a3f080febee448ba4d64c00cf.zip
net-misc/youtube-dl: Version 2019.04.30
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.04.30.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index b2341bae8445..29ca9379bcff 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2019.04.17.tar.gz 3146625 BLAKE2B 35f49bcb56daa3ddbeeaaab57e4be259ddd2ebd1b21f797098fecb33fc0e153947558406f91878e2bb2d2627c950b4e670dbde35a148f1c216e46d366a7bb462 SHA512 6277a96a6487d81be23e0772c8e6fa36337d5b2b90a50b9be328579334b92c6e1a6eb9634a66969435c0d47e734fb907e286578cbc2f693565055ed1111b8148
DIST youtube-dl-2019.04.24.tar.gz 3152789 BLAKE2B a90bc795d80c1dd50910288eead0646ffb0757afe911e3d3429b7ad20bcb9a494e12c341833731cbaf7009e0aef9d30695cf8e8c4e4688950709e96b02f10aff SHA512 44fa60c4e62bcc8d81908d600349ad89b1123262c942fe206d5966e7e2e59aca94d13e56bfac61b8be6da365316634aeb057b3d6055d6ff8b57addc1597d8fa3
+DIST youtube-dl-2019.04.30.tar.gz 3163152 BLAKE2B 9740bbbf883714f3c8017bca81b175a6179bb86b5226a284623a84afbd5c70d51010679c49eed3a3672fd7a147a5181b1a47d326c1fd4f403207dca7acf6a0c8 SHA512 db32d1162c11cd7850b162a48dd8f34bdfba142ab75fa3ac20088cf934cb9c6cfe44c0fc38bac173ae8056fe72aaae04e80b4ed47c162b1fdb1bdb2d95180ef6
diff --git a/net-misc/youtube-dl/youtube-dl-2019.04.30.ebuild b/net-misc/youtube-dl/youtube-dl-2019.04.30.ebuild
new file mode 100644
index 000000000000..20bf8606772f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.04.30.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}