summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-06 07:43:05 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-06 07:53:10 +0200
commitda0b9f2a69c0dccaef58d066a9fa13216d6b12fa (patch)
treea76b4345b277742fd2bd26f4446a6de6dbc67148 /net-misc/youtube-dl
parentdev-java/boot-bin: Add missing shebang re bug #682984 (diff)
downloadgentoo-da0b9f2a69c0dccaef58d066a9fa13216d6b12fa.tar.gz
gentoo-da0b9f2a69c0dccaef58d066a9fa13216d6b12fa.tar.bz2
gentoo-da0b9f2a69c0dccaef58d066a9fa13216d6b12fa.zip
net-misc/youtube-dl: Version 2019.08.02
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.08.02.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 734d09ca30d2..ee2a52f64b7a 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2019.07.16.tar.gz 3168500 BLAKE2B b88eb21c246b021b036822461a55b4c0fe1b0b4cc462a32c55f022c67a586fbbb98d8a943558c3b08289ff3cfaebd12adf558ef8a31cbf47b6679da5ed771417 SHA512 7dc71913210669521684ac0484ef02d20d7ce500d8fb72581d4f8c2978b369582ee003ea4e908e262cf1f7cd734b4e989d667a1fa36d6cf19e9fc0723c55d411
DIST youtube-dl-2019.07.27.tar.gz 3173039 BLAKE2B 8dfab65d0f30f01905fb19cdbcccb61aca955ce11fe9751bcad38542b879b97b5707bdcd9efd23c6769c9c76a6f78d6c074ddbc4ff3fa6fb52941e07a014a4db SHA512 f5d6d79097f5937d0ad0d491d922573d8fb288179d58475041783a7d245e9c200038856705e19cd74b156578594cff4cd09f9925c4fb915ff34ef4072be62ed5
+DIST youtube-dl-2019.08.02.tar.gz 3174224 BLAKE2B c5f3d0d210cc2dcc8e4d1170cfc44ade5095808fc1189b7e6dc5ce068ef421a70514d4e5af631d0d25e7ec68959d24ed988195b0f860c67f25898c177a9f8132 SHA512 9740fd8cb16ce73695ecc40017b8807d8a40d2df6bb7c1f89db00d0c490bd5a67718dffdf39b2b7d65071f01738c684a1deb520eef5efcf87f1e39ac8f3e103f
diff --git a/net-misc/youtube-dl/youtube-dl-2019.08.02.ebuild b/net-misc/youtube-dl/youtube-dl-2019.08.02.ebuild
new file mode 100644
index 000000000000..a8b1afbfc11a
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.08.02.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}