summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-02-01 17:27:56 +0100
committerMichael Weber <xmw@gentoo.org>2017-02-01 17:46:04 +0100
commit07a90a4b982ed644b6135c295c009a6ad7a35339 (patch)
tree9fe25143d3868da78155f319b8332faaca250f3e /net-misc
parentsys-kernel/vanilla-sources: Automated version bump to {3.12.70,4.4.46,4.9.7} ... (diff)
downloadgentoo-07a90a4b982ed644b6135c295c009a6ad7a35339.tar.gz
gentoo-07a90a4b982ed644b6135c295c009a6ad7a35339.tar.bz2
gentoo-07a90a4b982ed644b6135c295c009a6ad7a35339.zip
net-misc/hotot: Update live ebuild to enable building qt5 and gtk3 versions.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/hotot/hotot-9999.ebuild45
-rw-r--r--net-misc/hotot/metadata.xml2
2 files changed, 27 insertions, 20 deletions
diff --git a/net-misc/hotot/hotot-9999.ebuild b/net-misc/hotot/hotot-9999.ebuild
index 652b40a52220..ef84a2dc59e0 100644
--- a/net-misc/hotot/hotot-9999.ebuild
+++ b/net-misc/hotot/hotot-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils git-2 python-single-r1
+inherit cmake-utils git-r3 python-single-r1
DESCRIPTION="lightweight & open source microblogging client"
HOMEPAGE="http://hotot.org"
@@ -15,37 +15,42 @@ EGIT_REPO_URI="git://github.com/lyricat/Hotot.git"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="chrome gtk kde qt4"
+IUSE="chrome gtk2 gtk3 kde qt4 qt5"
-REQUIRED_USE="|| ( chrome gtk qt4 ) ${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="|| ( chrome gtk2 gtk3 qt4 qt5 ) ${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
dev-python/dbus-python[${PYTHON_USEDEP}]
- gtk? ( dev-python/pywebkitgtk[${PYTHON_USEDEP}] )
- qt4? ( dev-qt/qtwebkit:4
- kde? ( kde-frameworks/kdelibs:4 ) )"
+ gtk2? ( dev-python/pywebkitgtk[${PYTHON_USEDEP}] )
+ gtk3? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ net-libs/webkit-gtk:3[introspection] )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ kde? ( kde-frameworks/kdelibs:4 ) )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ )"
DEPEND="${RDEPEND}
sys-devel/gettext
qt4? ( dev-qt/qtsql:4 )"
-pkg_setup() {
- if ! use gtk ; then
- if ! use qt4 ; then
- ewarn "neither gtk not qt4 binaries will be build"
- fi
- fi
- python-single-r1_pkg_setup
-}
-
src_configure() {
mycmakeargs=(
${mycmakeargs}
$(cmake-utils_use_with chrome CHROME)
- $(cmake-utils_use_with gtk GTK)
- $(cmake-utils_use_with gtk GTK2)
- -DWITH_GTK3=OFF
+ $(cmake-utils_use_with gtk2 GTK)
+ $(cmake-utils_use_with gtk2 GTK2)
+ $(cmake-utils_use_with gtk3 GTK3)
$(cmake-utils_use_with kde KDE)
$(cmake-utils_use_with qt4 QT)
+ $(cmake-utils_use_with qt5 QT5)
-DPYTHON_EXECUTABLE=${PYTHON} )
cmake-utils_src_configure
diff --git a/net-misc/hotot/metadata.xml b/net-misc/hotot/metadata.xml
index 9fcc5c61b405..2c3b2c444fb1 100644
--- a/net-misc/hotot/metadata.xml
+++ b/net-misc/hotot/metadata.xml
@@ -7,6 +7,8 @@
</maintainer>
<use>
<flag name="chrome">Build chrome browser extension</flag>
+ <flag name="gtk2">Build gtk2 gui</flag>
+ <flag name="gtk3">Build gtk3 gui</flag>
</use>
<upstream>
<remote-id type="github">lyricat/Hotot</remote-id>