summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-10-23 10:15:21 +0200
committerSam James <sam@gentoo.org>2020-10-27 21:11:35 +0000
commit1ac0b00a5363be3c04d568f35f4a44ef39572195 (patch)
tree7be9f8eab6560a421dafa63daae89f0625c83fa4 /net-misc
parentmedia-gfx/gscan2pdf: require ImageMagick JPEG support for tests (diff)
downloadgentoo-1ac0b00a5363be3c04d568f35f4a44ef39572195.tar.gz
gentoo-1ac0b00a5363be3c04d568f35f4a44ef39572195.tar.bz2
gentoo-1ac0b00a5363be3c04d568f35f4a44ef39572195.zip
net-misc/unison: bump to 2.51.3_p20201024
has several fixes based on commit 73f1bfa from (Commits on Oct 24, 2020) https://github.com/bcpierce00/unison/commits/master shorten path in make_desktop_entry USE=doc to build unison-manual.pdf (no .html) Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/unison/Manifest1
-rw-r--r--net-misc/unison/unison-2.51.3_p20201024.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index cfc94fa8ec50..a5277f2845b3 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -5,3 +5,4 @@ DIST unison-2.51.2-manual.html 311981 BLAKE2B 1e1bc18d5bca5d50976b28c4e59cc27fcc
DIST unison-2.51.2-manual.pdf 518963 BLAKE2B 30d0010e7a11b10bb9fba3f5836e084452429f09a94cfcc639305d17ea69499eeeac1026a0bd35c785b08456d79b1b4c68c348c10237509c8cf4e45720d037e0 SHA512 170b280e5a9ad0fc4ed848aaa1c4a6a8977edfdcc133bf3288c03e1d4d6d20383cfa06593b9d149e746795945f6afb8d807cfa16f5cf8ab47795e3074776518d
DIST unison-2.51.2.tar.gz 691251 BLAKE2B 39f72e7229826ec1a2151b7d7af416d85ffe2f9e6f1277be77d2202088d41fa3aca45413b931e661d72b787710f7d3429352542554990bb638589d52f77fe43f SHA512 9ba24f8d46f3f8bf3c26ea1beb396e276a82a742d9e8479cb421ff9f97fa2051fc8fb809b5f47ebc88dcb6a04878e1bdeae8081540e35af710ccbdaead84c115
DIST unison-2.51.3.tar.gz 1370060 BLAKE2B 3e082c5de8c68d87fd4d061dbcf535b9001bd3bacd740fede4e94a239bc554e463c0493260748df61527304d2f874cb194f629fb1f066a47be5a5e54360f3cb7 SHA512 202bc592cf18d3ac76d7e29ec71add5d6e33a96b4b885e0e2add9a5a621db2290184f268c70e4f05e4884d6cdfed09f6fcd3dde85681c39628a10ea552917c8f
+DIST unison-2.51.3_p20201024.tar.gz 1371551 BLAKE2B 780cc176ed203345408551aaa11990e4da1ec0d4adfd928f3e8ff9c180f35fafb6ac097c00c95da8fe9178db122ea025e9f4336413f0694cea099ab80e2ae00e SHA512 87c7ce33621bc323607e901547da30b8fc0a842ba35128627f5d44fb4befd76ff94586ec1f8eb1f3359da756d09d8bf2481cf0d6eb2ea421113e0e4efdcbdf61
diff --git a/net-misc/unison/unison-2.51.3_p20201024.ebuild b/net-misc/unison/unison-2.51.3_p20201024.ebuild
new file mode 100644
index 000000000000..f0744e723563
--- /dev/null
+++ b/net-misc/unison/unison-2.51.3_p20201024.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+MY_COMMIT="73f1bfa2476f907e2d781948ce9e764230bf8b27"
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/"
+SRC_URI="https://github.com/bcpierce00/unison/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="debug doc gtk +ocamlopt threads"
+RESTRICT="!ocamlopt? ( strip )" # https://bugs.gentoo.org/685776#c0
+
+# ocaml version so we are sure it has ocamlopt use flag
+BDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ doc? ( app-text/dvipsk
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latex )"
+DEPEND="gtk? ( dev-ml/lablgtk:2= )"
+RDEPEND="gtk? ( dev-ml/lablgtk:2=
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ >=app-eselect/eselect-unison-0.4"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
+
+src_prepare() {
+ # https://github.com/bcpierce00/unison/issues/416
+ sed -e "/ifdef\ HEVEA/,/endif/d" -i doc/Makefile || die
+ # https://github.com/bcpierce00/unison/pull/415
+ sed -e "/myName/d" -i doc/docs.ml || die
+ default
+}
+
+src_compile() {
+ # build unison-manual.pdf but not .html
+ if use doc; then
+ local myconf="all docs HEVEA=false"
+ else
+ local myconf="all"
+ fi
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS=""
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ local binname
+ cd src || die
+ for binname in unison unison-fsmonitor; do
+ newbin ${binname} ${binname}-${SLOT}
+ done
+
+ if use gtk; then
+ newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
+ make_desktop_entry ${PN}-${SLOT} "${PN} (${SLOT})" "${PN}-${SLOT}"
+ fi
+
+ # Waiting for https://github.com/bcpierce00/unison/issues/411
+ if use doc; then
+ DOCS+=( ../doc/unison-manual.pdf )
+ # HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+ eselect unison update || die
+
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}