summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-04-21 09:47:06 +0200
committerJeroen Roovers <jer@gentoo.org>2016-04-21 09:47:06 +0200
commit26130351d7fab1714291b7e728aec7163734589e (patch)
tree5875b52d5edbd74a33535d7730f96624d32f9081 /net-misc
parentx11-misc/rofi: Add missing dependency (bug #580638 by Toralf Förster). (diff)
downloadgentoo-26130351d7fab1714291b7e728aec7163734589e.tar.gz
gentoo-26130351d7fab1714291b7e728aec7163734589e.tar.bz2
gentoo-26130351d7fab1714291b7e728aec7163734589e.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.04.19.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 0ccdb1445eca..c56f8cb827c7 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.04.06.tar.gz 2060723 SHA256 115a7443162198f12d97c2c1d83e69d462f78410a26d6dd5ae3c74603397b9cd SHA512 cd22fa19f17a78b5f45e3a765441ca61050f926a160772d1812f4cfecd982c6b36c9897cdd83dcdf3586bc9182d41644b768f7c2379fe12ee4b7269bc1937df0 WHIRLPOOL 2cb19483c7755557ba67d47d7e17112c9f784a9c16b22e887fe5c28e18ffe26e1741c7a7cd3f035b9b51520ce0d20e9ffd09890e9a8214d6173c0a4f846d974c
DIST youtube-dl-2016.04.13.tar.gz 2070544 SHA256 f9307cbf2f2e9baf4724d9a35beecd9c7728422c0bff5e9efd0e8a026cc952cb SHA512 8e704b0a1fdcabaf8fe211f2dfd7d14104741df08ba5778b1c1c8083828aff808179fed7179ce6bdac7b54bcdc73acfea687b08c6acab79cd091e3f8bc6896c8 WHIRLPOOL a3487fb37b05b8bae8e8ad9bae6cbf16677a7b088c5a146047ea8a8f35cf09dce581ea2c21a25ea9b99b6813e90873ad83d8c385dff229ac0d7d7fcb620582c6
+DIST youtube-dl-2016.04.19.tar.gz 2075147 SHA256 09ba62900703a1439659a5394d802c7b03fd3a7b35d604e94a256ae9ccd1b6a0 SHA512 96a5e8ed081355d6a4682355004b26c62385f89091a39ebaadd3cd4b655872db0e196dea44377e98d882d98581f6d5983aa3e7522d1292c4e57b86bcc252aa2b WHIRLPOOL ba8938c6fd34e4a7a32ccb16240ac1d48c2266cad46b2a79d02a2759c1a03d2bc2f2429e02674d6cf97fade60f44fdc9423d45c906eff9b64434977734ee081a
diff --git a/net-misc/youtube-dl/youtube-dl-2016.04.19.ebuild b/net-misc/youtube-dl/youtube-dl-2016.04.19.ebuild
new file mode 100644
index 000000000000..5cf89a1891a3
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.04.19.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn malemotion mofosex
+ motherless myvidster porn91 pornhd pornotube pornovoisines pornoxo
+ redtube ruleporn sexu sexykarma slutload spankbang spankwire
+ sunporno thisav trutube tube8 vporn xbef xnxx xtube xvideos
+ xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}