summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-04-13 08:44:10 +0200
committerJeroen Roovers <jer@gentoo.org>2016-04-13 08:44:10 +0200
commit27671facfe1ec9a855050ff54dd6e58bf13ec670 (patch)
tree8574fce97e590e4c9f9806911443512711c502e1 /net-misc
parentdev-lang/julia: require USE=threads for sci-libs/fftw (diff)
downloadgentoo-27671facfe1ec9a855050ff54dd6e58bf13ec670.tar.gz
gentoo-27671facfe1ec9a855050ff54dd6e58bf13ec670.tar.bz2
gentoo-27671facfe1ec9a855050ff54dd6e58bf13ec670.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.04.13.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 5a91f4cddcfd..7878d525f4ca 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.03.18.tar.gz 2022466 SHA256 1322afa755bc84531d1ede700a5fa2a6abb815b13a9382b83b78c5193f56fb8a SHA512 46f955a104155f44cf003acff350c7d94f6b206cb0e0026fd8bbbf1041553fca2ca2d3796bb8e9f1c6417be829b77c2c89dc0816229488fe806fae766d62ec03 WHIRLPOOL 2382ebbf4b4a694dfae9d8627d6fbc4749bfc4ae1755ec0a102dbfd0ae10d91f0207c1e84f67d5cb68d564ad86d37776ac421e857ef711ca6a75983689edbf45
DIST youtube-dl-2016.03.27.tar.gz 2047145 SHA256 472e5d0b5907ace17267974ca8f3548c02c44c6ff679ab10ee01987873285dbf SHA512 ce7c3767e68844ed36a552b43e0f01903aadf0f8889e67b13d3679cf77dda80c739b7938c094dc5a0eb2073c5f3a0d032b40b184a50e5a2c25f9877efca12c75 WHIRLPOOL 0f6ba03d32c1a035ddffc4d7949dbe6c6bef16fc540ab63bffec04cef3d489f6b61914c2036d99c54091689a8ded35607500b783c5f626e79c7175a8b80de7bf
DIST youtube-dl-2016.04.06.tar.gz 2060723 SHA256 115a7443162198f12d97c2c1d83e69d462f78410a26d6dd5ae3c74603397b9cd SHA512 cd22fa19f17a78b5f45e3a765441ca61050f926a160772d1812f4cfecd982c6b36c9897cdd83dcdf3586bc9182d41644b768f7c2379fe12ee4b7269bc1937df0 WHIRLPOOL 2cb19483c7755557ba67d47d7e17112c9f784a9c16b22e887fe5c28e18ffe26e1741c7a7cd3f035b9b51520ce0d20e9ffd09890e9a8214d6173c0a4f846d974c
+DIST youtube-dl-2016.04.13.tar.gz 2070544 SHA256 f9307cbf2f2e9baf4724d9a35beecd9c7728422c0bff5e9efd0e8a026cc952cb SHA512 8e704b0a1fdcabaf8fe211f2dfd7d14104741df08ba5778b1c1c8083828aff808179fed7179ce6bdac7b54bcdc73acfea687b08c6acab79cd091e3f8bc6896c8 WHIRLPOOL a3487fb37b05b8bae8e8ad9bae6cbf16677a7b088c5a146047ea8a8f35cf09dce581ea2c21a25ea9b99b6813e90873ad83d8c385dff229ac0d7d7fcb620582c6
diff --git a/net-misc/youtube-dl/youtube-dl-2016.04.13.ebuild b/net-misc/youtube-dl/youtube-dl-2016.04.13.ebuild
new file mode 100644
index 000000000000..25402e2d76c7
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.04.13.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn malemotion mofosex
+ motherless myvidster porn91 pornhd pornotube pornovoisines pornoxo
+ redtube ruleporn sexu sexykarma slutload spankbang spankwire
+ sunporno thisav trutube tube8 vporn xbef xnxx xtube xvideos
+ xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}