summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-03-04 22:40:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-03-04 22:41:21 -0600
commit323451a495863127d1b5e542310d114e070dcb0b (patch)
tree838dd6d9d6301032274b9b0746438235026421c6 /net-misc
parentdev-python/ovs: bup (diff)
downloadgentoo-323451a495863127d1b5e542310d114e070dcb0b.tar.gz
gentoo-323451a495863127d1b5e542310d114e070dcb0b.tar.bz2
gentoo-323451a495863127d1b5e542310d114e070dcb0b.zip
net-misc/openvswitch: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvswitch/Manifest1
-rw-r--r--net-misc/openvswitch/openvswitch-2.7.0.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index 27b53e07ab07..a1ce1ccc3fdb 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -4,3 +4,4 @@ DIST openvswitch-2.1.3.tar.gz 3080126 SHA256 43a2562fe5e8e48e997bfdb04691ffaaaef
DIST openvswitch-2.5.0.tar.gz 4603077 SHA256 34da54fbad503205b1a66b48ca4312679e1ce5b04763a9fb86050b2b25d66f21 SHA512 32addb6ed8d4b78e6eb5b951de6b2390dacb3a66096ff8de6020e6d42d460e1038eec43c4057707942f8043ebcad848488d09c7aabfa4599d53782a9cc69f089 WHIRLPOOL 3b879ce376268bb65858f4c4b7193c54fc43a9903029f2000cee1a4f8739eae3ed5b2ad67c57de7ecfe3028874831796bd69a1b8a0599d9dad56f1b524302c5d
DIST openvswitch-2.6.0.tar.gz 5386102 SHA256 c6f86b47b5847e739ca1c5a80059a804cd49e2b98eefef0fdbce1c4d93c7d0f1 SHA512 7bcf02a00b94924e7931642790f40a49b86338baa63405e9454bff20b82d5a53bbc43279c223946f082d050c73ce6caedcb8a1e52979c873262bc9e8ff84b42d WHIRLPOOL d275071d3491167d3672966381403e704580797eb53fb8d8da2de3c08efd614a709d70af256172670271601d8d90a1350f1c2fae0e9236f729b6c278d5038513
DIST openvswitch-2.6.1.tar.gz 5399107 SHA256 307b20aba6a179bf13e5da9ac242933c31349073762473a9d4782619c8c1cf0c SHA512 c5a716d2d9ac5f353827a4ad1e26f4d0ddfc4d7bf1e8f696043c32676e77c068e3e0dd423348cc33d5507753d7a27ce24898b823dad3fbc6a8d79297fa088b39 WHIRLPOOL 1ab35852ad45fc99964c814923ea54b22ec6c4630b2aa6cb6aee7b96ca806095d0be60c1b08f926419efa79a3c7ce4d484efe497bb50a9596db69b6020175092
+DIST openvswitch-2.7.0.tar.gz 6149523 SHA256 e492cf08a929b4a2178b7f9b01dc4ff562f44138b547b4e942078187b2445d2e SHA512 d0c61fa149f5279182de561ed82125e7ddd4ecd4278eba3c5e6a7221840c8cbb70581269afdf4ff2508b8e5baeb8783b1a196d6e6f747e3a21aacdf778d6d190 WHIRLPOOL 0c26e4488bfd3bea97415d9b4b00c87730bb35c2c059f3aff2fb0f7d3e34eed6308a4734ab88395dc435bd670ef584d89af9849d0cf6ea9dfe78168329e098cd
diff --git a/net-misc/openvswitch/openvswitch-2.7.0.ebuild b/net-misc/openvswitch/openvswitch-2.7.0.ebuild
new file mode 100644
index 000000000000..39ad5813acae
--- /dev/null
+++ b/net-misc/openvswitch/openvswitch-2.7.0.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools eutils linux-info linux-mod python-r1 systemd
+
+DESCRIPTION="Production quality, multilayer virtual switch"
+HOMEPAGE="http://openvswitch.org"
+SRC_URI="http://openvswitch.org/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug modules monitor +ssl"
+
+RDEPEND="
+ || (
+ >=sys-apps/openrc-0.10.5
+ sys-apps/systemd
+ )
+ ssl? ( dev-libs/openssl:0= )
+ ${PYTHON_DEPS}
+ ~dev-python/ovs-${PV}
+ dev-python/twisted-core
+ dev-python/twisted-conch
+ dev-python/twisted-web
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ debug? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES="${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
+
+CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ if use modules ; then
+ CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ kernel_is le 4 9 999 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ linux-mod_pkg_setup
+ else
+ CONFIG_CHECK+=" ~OPENVSWITCH"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Never build kernelmodules, doing this manually
+ sed -i \
+ -e '/^SUBDIRS/d' \
+ datapath/Makefile.in || die "sed failed"
+ eautoreconf
+ default
+}
+
+src_configure() {
+ set_arch_to_kernel
+ # monitor is statically enabled for bug 596206
+ use monitor || export ovs_cv_python="no"
+ # pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
+
+ local linux_config
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+
+ econf ${linux_config} \
+ --with-rundir=/var/run/openvswitch \
+ --with-logdir=/var/log/openvswitch \
+ --with-pkidir=/etc/ssl/openvswitch \
+ --with-dbdir=/var/lib/openvswitch \
+ $(use_enable ssl) \
+ $(use_enable !debug ndebug)
+}
+
+src_compile() {
+ default
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ default
+
+ local SCRIPT
+ if use monitor; then
+ for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
+ sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
+ python_foreach_impl python_doscript utilities/"${SCRIPT}"
+ done
+ rm -r "${ED%/}"/usr/share/openvswitch/python || die
+ fi
+
+ keepdir /var/{lib,log}/openvswitch
+ keepdir /etc/ssl/openvswitch
+ fperms 0750 /etc/ssl/openvswitch
+
+ rm -rf "${ED%/}"/var/run || die
+
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
+ newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
+ newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
+ newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
+
+ systemd_dounit "${FILESDIR}/ovsdb-server.service"
+ systemd_dounit "${FILESDIR}/ovs-vswitchd.service"
+ systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
+
+ insinto /etc/logrotate.d
+ newins rhel/etc_logrotate.d_openvswitch openvswitch
+
+ use modules && linux-mod_src_install
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ local pv
+ for pv in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 1.9.0 ${pv} ; then
+ ewarn "The configuration database for Open vSwitch got moved in version 1.9.0 from"
+ ewarn " /etc/openvswitch"
+ ewarn "to"
+ ewarn " /var/lib/openvswitch"
+ ewarn "Please copy/move the database manually before running the schema upgrade."
+ ewarn "The PKI files are now supposed to go to /etc/ssl/openvswitch"
+ fi
+ done
+
+ elog "Use the following command to create an initial database for ovsdb-server:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "(will create a database in /var/lib/openvswitch/conf.db)"
+ elog "or to convert the database to the current schema after upgrading."
+}
+
+pkg_config() {
+ local db="${EROOT%/}"/var/lib/openvswitch/conf.db
+ if [[ -e "${db}" ]] ; then
+ einfo "Database '${db}' already exists, doing schema migration..."
+ einfo "(if the migration fails, make sure that ovsdb-server is not running)"
+ ovsdb-tool convert "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
+ else
+ einfo "Creating new database '${db}'..."
+ ovsdb-tool create "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
+ fi
+}