summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-04 04:28:36 +0100
committerSam James <sam@gentoo.org>2022-08-04 04:28:36 +0100
commit33dd70bb90720c7b8afc19f0ac105257750dfbd7 (patch)
tree3aef1d2463e159999d043a002d8c58d00c780853 /net-misc
parentdev-util/gitlab-runner: add 15.2.1 (diff)
downloadgentoo-33dd70bb90720c7b8afc19f0ac105257750dfbd7.tar.gz
gentoo-33dd70bb90720c7b8afc19f0ac105257750dfbd7.tar.bz2
gentoo-33dd70bb90720c7b8afc19f0ac105257750dfbd7.zip
net-misc/mosh: add 1.4.0_rc1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mosh/Manifest1
-rw-r--r--net-misc/mosh/mosh-1.4.0_rc1.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/net-misc/mosh/Manifest b/net-misc/mosh/Manifest
index 528cca3c4325..b648ef755aec 100644
--- a/net-misc/mosh/Manifest
+++ b/net-misc/mosh/Manifest
@@ -1 +1,2 @@
DIST mosh-1.3.2.tar.gz 359574 BLAKE2B 0b7290da0c5e5af0bfed58594095cb2649fec049fda7c495df326742176033d1716752451d2a9f11ba2c2957e8b8fecd5caa4e8962c8597e8dd67d1de7582ec5 SHA512 f400e8fe7ba2ab7362311fc12a00ec69587505f901988aeee500fc68d38a388218500a3f602111c883ff23a9d43572114fcf0a8bf505df203691e5b597615769
+DIST mosh-1.4.0-rc1.tar.gz 386364 BLAKE2B e9dee52f0a0d934c85efbcfd7c6b857ad1b6e3d5a7ed13730e1a79ef286331ef1828292ebc71731572af94c03bae37b7227ff569669c01b6885984b15220693e SHA512 82affca6a596a0475f32a944e23c879f625215ea8311cd29cef56f5af57d88a377420ba7addeb53c9bd30d1583654897baf939618e706d1928d57e83cc87ce9c
diff --git a/net-misc/mosh/mosh-1.4.0_rc1.ebuild b/net-misc/mosh/mosh-1.4.0_rc1.ebuild
new file mode 100644
index 000000000000..cc24a1f0f45c
--- /dev/null
+++ b/net-misc/mosh/mosh-1.4.0_rc1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+MY_P=${PN}-${PV/_/-}
+DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
+HOMEPAGE="https://mosh.org"
+#SRC_URI="https://mosh.org/${P}.tar.gz"
+SRC_URI="https://github.com/mobile-shell/mosh/releases/download/${MY_P}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+IUSE="+client examples +mosh-hardening +server syslog ufw +utempter"
+
+REQUIRED_USE="
+ || ( client server )
+ examples? ( client )"
+
+RDEPEND="
+ dev-libs/openssl:=
+ dev-libs/protobuf:=
+ sys-libs/ncurses:=
+ sys-libs/zlib
+ virtual/ssh
+ client? (
+ dev-lang/perl
+ dev-perl/IO-Tty
+ )
+ utempter? (
+ sys-libs/libutempter
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+QA_CONFIGURE_OPTIONS="--disable-static"
+
+# [0] - avoid sandbox-violation calling git describe in Makefile.
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.5-git-version.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ MAKEOPTS+=" V=1"
+
+ local myeconfargs=(
+ # We install it ourselves in src_install
+ --disable-completion
+
+ $(use_enable client)
+ $(use_enable server)
+ $(use_enable examples)
+ $(use_enable ufw)
+ $(use_enable mosh-hardening hardening)
+ $(use_enable syslog)
+ $(use_with utempter)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ for myprog in $(find src/examples -type f -perm /0111) ; do
+ newbin ${myprog} ${PN}-$(basename ${myprog})
+ elog "${myprog} installed as ${PN}-$(basename ${myprog})"
+ done
+
+ # bug #477384
+ dobashcomp conf/bash-completion/completions/mosh
+}