summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-03-05 14:50:03 +0200
committerMichał Górny <mgorny@gentoo.org>2017-03-05 15:37:37 +0100
commit3d599eb34b8863664dcf6b02ffe6da7b681e3a31 (patch)
tree52190947999c15a4c46d5abdce8e1e243e376bab /net-misc
parentnet-misc/streamlink: update live ebuild (diff)
downloadgentoo-3d599eb34b8863664dcf6b02ffe6da7b681e3a31.tar.gz
gentoo-3d599eb34b8863664dcf6b02ffe6da7b681e3a31.tar.bz2
gentoo-3d599eb34b8863664dcf6b02ffe6da7b681e3a31.zip
net-misc/streamlink: version bump to 0.3.2
Closes: https://github.com/gentoo/gentoo/pull/2975
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-0.3.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index bc0fd6172d50..aa640f330ef8 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1 +1,2 @@
DIST streamlink-0.1.0.tar.gz 960622 SHA256 0a792cfe35c36f13b851bb79dc92e8a9515334c49221297258c9998f191ccecd SHA512 78b5bd9d35c2fc9c1d9fe3954b439e56cfee48f2b73a95a2c08a53c3a66143938ba162f2d2ba29c8af989565c920756cab605ae772d73828a3dd5a41fc6d30c2 WHIRLPOOL 5ba5dc69aecb06d8b1ba5372a327033b06d88bd38040278df0cac06c84663f7dcef29ae0921c4f36959a53eac7621d8df184bf9ea9bf5cbf6e5b2b2d7b4c8f23
+DIST streamlink-0.3.2.tar.gz 30660501 SHA256 b126a0d2c964a513c3b5474b457bc5faf3dbb17aa8b43c4c8f6d633e29b2738e SHA512 7de2aae1e9a6e3c81d0274d7ef68847ead166c6085dfc876a10d1c6715f2971195d9527e773ae6d4258f61db802bc3a9d837d346b6eae03c1275ecb58f464067 WHIRLPOOL 3cf1912761f4ed755048422e7bc482bf908016ad3256c1ce0d140d107fe1bee4c77aff6bf839fcdf895b92327aae226c982afc8172a1a375484bbddc3e36075b
diff --git a/net-misc/streamlink/streamlink-0.3.2.ebuild b/net-misc/streamlink/streamlink-0.3.2.ebuild
new file mode 100644
index 000000000000..172391eae04c
--- /dev/null
+++ b/net-misc/streamlink/streamlink-0.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 MIT"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
+ dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ media-video/rtmpdump
+ virtual/ffmpeg"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[$(python_gen_usedep 'python2*')]
+ ${RDEPEND} )"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}