summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-05-21 11:16:54 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-05-21 11:17:33 +0200
commit400e119ac1526afbf95c5e642c4f84eb6195f158 (patch)
tree03d854e29285a9bc1f63177b4259c24efe10b2a0 /net-misc
parentsys-fs/xwmfs: removal of old version 0.82-r1 (diff)
downloadgentoo-400e119ac1526afbf95c5e642c4f84eb6195f158.tar.gz
gentoo-400e119ac1526afbf95c5e642c4f84eb6195f158.tar.bz2
gentoo-400e119ac1526afbf95c5e642c4f84eb6195f158.zip
net-misc/istioctl: Version bump to 1.1.7
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/istioctl/Manifest1
-rw-r--r--net-misc/istioctl/istioctl-1.1.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/istioctl/Manifest b/net-misc/istioctl/Manifest
index ef21be2524de..088b03cec6c1 100644
--- a/net-misc/istioctl/Manifest
+++ b/net-misc/istioctl/Manifest
@@ -1,2 +1,3 @@
DIST istioctl-1.1.4.tar.gz 20705247 BLAKE2B d3727dafcfa8a630a02040fe452a3a2b6c89d4dc2ede4128b9906adf21d97e68f8b126783d248239416a459357bee72ca0f2af19a6d34039ad59b3ade6f3b6d1 SHA512 e866fcad482ef605e4126fffe421eff7fbc1733e5d949e2ebe846f790d8825bb79d5360fe48d29913f0b015c15bc1aac224ac9f39e4e7d5948f2dcd5042570a8
DIST istioctl-1.1.6.tar.gz 20707819 BLAKE2B 0ebd34873e6ff1fec2413afed8b4fe80baee8e9bec55bc2fab15b25266b404fb05fce6bfd0e122c5eb3fa661f5633a431aaa3042ad6d12caf2c4feb58bdbaa5e SHA512 62b9b96547af6f8050f934e4d620ab1990afc805c0abbdbc7933220d28676542222b4452f8207dbe5976116bfe8ae557ee7545e1859b0ab22d9c0c2510950fca
+DIST istioctl-1.1.7.tar.gz 20711283 BLAKE2B 5c6d54ab033f0dba19377d0ca1a88a57e319932c91d3c2c1f3ad9fc112f11aec481e4421b958490e5b3c24d3be6ae68dbc7122e17a7463585a052e225f77ae5b SHA512 8a00efd3fea05d3b28225bf6d58d46769aa7576851df849185d62a14ef368980df765d3c5b1d9c59dff7f0034259e62fe57bc119b66cecb220513f7b94500cef
diff --git a/net-misc/istioctl/istioctl-1.1.7.ebuild b/net-misc/istioctl/istioctl-1.1.7.ebuild
new file mode 100644
index 000000000000..2d1aca58a468
--- /dev/null
+++ b/net-misc/istioctl/istioctl-1.1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+GIT_COMMIT="eec7a74473deee98cad0a996f41a32a47dd453c2"
+
+KEYWORDS="~amd64"
+DESCRIPTION="Istio configuration command line utility"
+EGO_PN="istio.io/istio"
+HOMEPAGE="https://github.com/istio/istio"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/istio/istio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd "src/${EGO_PN}" || die
+ BUILDINFO="istio.io/istio/pkg/version.buildVersion=${PV}
+ istio.io/istio/pkg/version.buildGitRevision=${GIT_COMMIT}
+ istio.io/istio/pkg/version.buildStatus=Clean" \
+ VERBOSE=1 GOPATH="${WORKDIR}/${P}" TAG=${PV} emake istioctl
+ popd || die
+}
+
+src_install() {
+ dobin out/linux_amd64/release/${PN}
+ pushd "src/${EGO_PN}" || die
+ dodoc README.md
+}