summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-16 09:12:02 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-16 09:13:09 -0400
commit40e0ef0dfdf66ca92e2cb5b5b70d78941e175377 (patch)
treef5e0e60274af0a2e7c9b986c1f5483c2038c22d6 /net-misc
parentdev-ruby/redis: Remove ruby19 (diff)
downloadgentoo-40e0ef0dfdf66ca92e2cb5b5b70d78941e175377.tar.gz
gentoo-40e0ef0dfdf66ca92e2cb5b5b70d78941e175377.tar.bz2
gentoo-40e0ef0dfdf66ca92e2cb5b5b70d78941e175377.zip
net-misc/libreswan: bump to 3.17
Package-Manager: portage-2.2.28_p64
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/libreswan/Manifest1
-rw-r--r--net-misc/libreswan/libreswan-3.17.ebuild99
-rw-r--r--net-misc/libreswan/libreswan-9999.ebuild11
3 files changed, 104 insertions, 7 deletions
diff --git a/net-misc/libreswan/Manifest b/net-misc/libreswan/Manifest
index a3f98f051140..43477c637bde 100644
--- a/net-misc/libreswan/Manifest
+++ b/net-misc/libreswan/Manifest
@@ -1 +1,2 @@
DIST libreswan-3.15.tar.gz 9256911 SHA256 1ca370105a2a619eb4dc34626cb53cd391391e953fce3761a83f0e3a4d5aec4c SHA512 6472906d2507b7f4a06bf608b701e5982d5987b47d9ef88e5c8e63284f8d4d1a7155dd732d6daf8312d53c159bc344a54b2be173339a57aedea19caa79a13fb9 WHIRLPOOL 7fb86556e6b661523966eafdcde6796477f7173c573aece840f0f1f6a6dbfbda132a0723567334944ef5e23815150aef968f2761f842932228dca8c74ede1377
+DIST libreswan-3.17.tar.gz 9168223 SHA256 28c286f57f6d8d00e1502ea283aac0f9f863edb2d759e50dc89df0e28c0d0d03 SHA512 4503ae82663f060f3af3fd74491ae94feb33a28f13f96cd04bb4a83bba17fe199f4ff7cba83850235829b373f803ba816d7a4199d4afb1da191c7323dd28a362 WHIRLPOOL c771218d7c0a26041bb946c2805f581086e9beae8827c2fbaad49eb032107f322316e6102b3161db014d1d6e5e222d682d23a1ac147ae65fc37b0c364440cbdc
diff --git a/net-misc/libreswan/libreswan-3.17.ebuild b/net-misc/libreswan/libreswan-3.17.ebuild
new file mode 100644
index 000000000000..2fd8e0c08caa
--- /dev/null
+++ b/net-misc/libreswan/libreswan-3.17.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://download.libreswan.org/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libreswan/libreswan.git"
+fi
+
+DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
+HOMEPAGE="https://libreswan.org/"
+
+LICENSE="GPL-2 BSD-4 RSA DES"
+SLOT="0"
+IUSE="caps curl dnssec ldap pam"
+
+COMMON_DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libevent
+ dev-libs/nspr
+ caps? ( sys-libs/libcap-ng )
+ curl? ( net-misc/curl )
+ dnssec? ( net-dns/unbound net-libs/ldns )
+ ldap? ( net-nds/openldap )
+ pam? ( sys-libs/pam )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ dev-libs/nss
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/nss[utils(+)]
+ sys-apps/iproute2
+ !net-misc/openswan
+ !net-misc/strongswan
+"
+
+usetf() {
+ usex "$1" true false
+}
+
+src_configure() {
+ tc-export AR CC
+ export INC_USRLOCAL=/usr
+ export INC_MANDIR=share/man
+ export FINALEXAMPLECONFDIR=/usr/share/doc/${PF}
+ export FINALDOCDIR=/usr/share/doc/${PF}/html
+ export INITSYSTEM=openrc
+ export INC_RCDIRS=
+ export INC_RCDEFAULT=/etc/init.d
+ export USERCOMPILE=
+ export USERLINK=
+ export USE_DNSSEC=$(usetf dnssec)
+ export USE_LIBCAP_NG=$(usetf caps)
+ export USE_LIBCURL=$(usetf curl)
+ export USE_LDAP=$(usetf ldap)
+ export USE_XAUTHPAM=$(usetf pam)
+ export DEBUG_CFLAGS=
+ export OPTIMIZE_CFLAGS=
+ export WERROR_CFLAGS=
+}
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ echo "include /etc/ipsec.d/*.secrets" > "${D}"/etc/ipsec.secrets
+ fperms 0600 /etc/ipsec.secrets
+
+ systemd_dounit "${FILESDIR}/ipsec.service"
+
+ dodoc CHANGES README
+ dodoc -r docs
+
+ find "${D}" -type d -empty -delete || die
+}
+
+pkg_postinst() {
+ local IPSEC_CONFDIR=${ROOT%/}/etc/ipsec.d
+ if [[ ! -f ${IPSEC_CONFDIR}/cert8.db ]]; then
+ ebegin "Setting up NSS database in ${IPSEC_CONFDIR}"
+ certutil -N -d "${IPSEC_CONFDIR}" -f <(echo)
+ eend $?
+ fi
+}
diff --git a/net-misc/libreswan/libreswan-9999.ebuild b/net-misc/libreswan/libreswan-9999.ebuild
index 732f27d72b61..2fd8e0c08caa 100644
--- a/net-misc/libreswan/libreswan-9999.ebuild
+++ b/net-misc/libreswan/libreswan-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils systemd toolchain-funcs
+inherit systemd toolchain-funcs
if [[ ${PV} != 9999 ]]; then
SRC_URI="https://download.libreswan.org/${P}.tar.gz"
@@ -46,10 +46,6 @@ RDEPEND="${COMMON_DEPEND}
!net-misc/strongswan
"
-src_prepare() {
- epatch_user
-}
-
usetf() {
usex "$1" true false
}
@@ -72,6 +68,7 @@ src_configure() {
export USE_XAUTHPAM=$(usetf pam)
export DEBUG_CFLAGS=
export OPTIMIZE_CFLAGS=
+ export WERROR_CFLAGS=
}
src_compile() {