summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:07:50 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:08:37 -0500
commit44c9289ba797653d62f7e08233e6dbdf187be263 (patch)
tree8fd827bb0d5d0d080db40e7b5a7be0f0f818816f /net-misc
parentnet-misc/linux-identd: remove old version (diff)
downloadgentoo-44c9289ba797653d62f7e08233e6dbdf187be263.tar.gz
gentoo-44c9289ba797653d62f7e08233e6dbdf187be263.tar.bz2
gentoo-44c9289ba797653d62f7e08233e6dbdf187be263.zip
net-misc/mdidentd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mdidentd/files/mdidentd.init.d4
-rw-r--r--net-misc/mdidentd/mdidentd-1.04c-r1.ebuild50
2 files changed, 52 insertions, 2 deletions
diff --git a/net-misc/mdidentd/files/mdidentd.init.d b/net-misc/mdidentd/files/mdidentd.init.d
index a21e287d6fe1..8144c09c94be 100644
--- a/net-misc/mdidentd/files/mdidentd.init.d
+++ b/net-misc/mdidentd/files/mdidentd.init.d
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/mdidentd/mdidentd-1.04c-r1.ebuild b/net-misc/mdidentd/mdidentd-1.04c-r1.ebuild
new file mode 100644
index 000000000000..8dd559ef2778
--- /dev/null
+++ b/net-misc/mdidentd/mdidentd-1.04c-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="This is an identd with provides registering of idents"
+HOMEPAGE="http://druglord.freelsd.org/ezbounce/"
+SRC_URI="http://druglord.freelsd.org/ezbounce/files/ezbounce-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/ezbounce-${PV}
+
+pkg_setup() {
+ enewgroup mdidentd
+ enewuser mdidentd -1 -1 /dev/null mdidentd
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/1.04a-security.patch
+ eapply -p0 "${FILESDIR}"/1.04a-pidfile.patch
+ eapply -p1 "${FILESDIR}"/1.04a-glibc210.patch
+
+ default
+}
+
+src_configure() {
+ econf $(use_with ssl)
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" -C mdidentd CXX_OPTIMIZATIONS="${CXXFLAGS}"
+}
+
+src_install() {
+ dosbin mdidentd/mdidentd
+ dodoc mdidentd/README
+
+ newinitd "${FILESDIR}"/mdidentd.init.d mdidentd
+ newconfd "${FILESDIR}"/mdidentd.conf.d mdidentd
+}