summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-09 10:58:33 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-09 10:58:33 +0200
commit54ee75a97f966af1ed6eba2a0843a1d44dc1a63c (patch)
tree41a4a58b3a20195b691778370a545eae4d497ab0 /net-misc
parentdev-python/wheel: Stable for PPC64 (bug #583704). (diff)
downloadgentoo-54ee75a97f966af1ed6eba2a0843a1d44dc1a63c.tar.gz
gentoo-54ee75a97f966af1ed6eba2a0843a1d44dc1a63c.tar.bz2
gentoo-54ee75a97f966af1ed6eba2a0843a1d44dc1a63c.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.10.07.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index c2573a099ef8..9e428252b3ec 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.10.02.tar.gz 2417904 SHA256 ecc58e3661c70ed3eeb46712461ad53f92d0b815d4030466d6a29eca9f6869ba SHA512 23d964de978eb313173f9d602bde580550a53fe09007854d2da943988b8bdabcc6ba5856303083c86f2af618e63ec2d41b6e6c68cc230c522fe4ccb7ad899257 WHIRLPOOL b5c53dfec5bcbeb97969ea66f74d6d70afeed3c1d8b2cf080d387d41586a4b5118c27bade32f227583f56e4986f76c46359ba19c8a6909284cdb62d6d0ef4a4c
+DIST youtube-dl-2016.10.07.tar.gz 2425722 SHA256 56be6107275cbdc867e89caf9d20f351d184fdc4fb06d915945fef708086dbce SHA512 59cc697ff3edd0fc70122624d921ecad620a6c8279051c159b52891cf0818f67661de8957ee2e6aba23c347c80aa0ac2ef384bbb1c5a949b5c3f5d8de24ddf11 WHIRLPOOL dfa85b40ca845d5b2fc3c59d5433d9c7720b03b4efdb10c6b8e929e4cb3848523b1413b33abc0aec78c4fe55874da34c22370a7bd94314539eb2b7875b9a068b
diff --git a/net-misc/youtube-dl/youtube-dl-2016.10.07.ebuild b/net-misc/youtube-dl/youtube-dl-2016.10.07.ebuild
new file mode 100644
index 000000000000..1f0ca43a4f19
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.10.07.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}