summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-08-17 19:08:40 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-08-17 19:10:19 +0200
commit6c249aeddfa46bcba7b83eecb8d65513f77602f0 (patch)
tree0f7fc0d73a66d512e61489c122d2276aa5b908e7 /net-misc
parentgames-engines/openmw: fix build with boost-1.77.0 (diff)
downloadgentoo-6c249aeddfa46bcba7b83eecb8d65513f77602f0.tar.gz
gentoo-6c249aeddfa46bcba7b83eecb8d65513f77602f0.tar.bz2
gentoo-6c249aeddfa46bcba7b83eecb8d65513f77602f0.zip
net-misc/oidentd: add missing deps
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/oidentd/oidentd-3.0.0-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/oidentd/oidentd-3.0.0-r1.ebuild b/net-misc/oidentd/oidentd-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..614fff09c55e
--- /dev/null
+++ b/net-misc/oidentd/oidentd-3.0.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Another (RFC1413 compliant) ident daemon"
+HOMEPAGE="https://oidentd.janikrabe.com/"
+SRC_URI="https://files.janikrabe.com/pub/${PN}/releases/${PV}/${P}.tar.xz"
+
+LICENSE="BSD-2 GPL-2 LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug ipv6 masquerade selinux"
+
+DEPEND="masquerade? ( net-libs/libnetfilter_conntrack )"
+
+RDEPEND="
+ ${DEPEND}
+ acct-user/oidentd
+ acct-group/oidentd
+ selinux? ( sec-policy/selinux-oident )
+"
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_prepare() {
+ sed -i '/ExecStart/ s|$| -u oidentd -g oidentd|' contrib/systemd/*.service || die
+
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable masquerade libnfct)
+ $(use_enable masquerade nat)
+ --enable-xdgbdir
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.7-init ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.2.2-confd ${PN}
+
+ systemd_dounit contrib/systemd/${PN}@.service
+ systemd_dounit contrib/systemd/${PN}.socket
+ systemd_dounit contrib/systemd/${PN}.service
+}