summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2015-10-16 15:27:15 +0200
committerMatthew Brewer <tomboy64@sina.cn>2015-10-19 15:09:58 +0200
commit74cd99dd20d22a39df61ef17df2b55fd74c891eb (patch)
treeb3560909f1155b6d3ba27cfccbd8343c89c5820c /net-misc
parentprofiles: Mask dev-java/commons-attributes and dev-java/xjavadoc (diff)
downloadgentoo-74cd99dd20d22a39df61ef17df2b55fd74c891eb.tar.gz
gentoo-74cd99dd20d22a39df61ef17df2b55fd74c891eb.tar.bz2
gentoo-74cd99dd20d22a39df61ef17df2b55fd74c891eb.zip
net-misc/sx: new ebuild
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/sx/Manifest1
-rw-r--r--net-misc/sx/metadata.xml17
-rw-r--r--net-misc/sx/sx-1.2.ebuild46
3 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/sx/Manifest b/net-misc/sx/Manifest
new file mode 100644
index 000000000000..cac19f7f39b6
--- /dev/null
+++ b/net-misc/sx/Manifest
@@ -0,0 +1 @@
+DIST sx-1.2.tar.gz 7218016 SHA256 98c37a84e1653364226aff47e63b715500636c0af3b20f4e74eefe3397ee2d63 SHA512 b1366cd7968b678a877d163e4183d7dbdc1b1d0a90fd1a8bc9e795cbbeb75677e6f15da7f770c77e61cf97ed20c27acc5ab1d17d25cd1c5f1f40271ced42b41a WHIRLPOOL 4dbb5453b4123bfe5380e604ad2782e66642b442e2e2b2609d847de4e06a1bb543231273f55c4605f9562c3936f8c91a150851182fbed3150c92402c44ad16c5
diff --git a/net-misc/sx/metadata.xml b/net-misc/sx/metadata.xml
new file mode 100644
index 000000000000..32f6c93e6b37
--- /dev/null
+++ b/net-misc/sx/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>tomboy64@sina.cn</email>
+ </maintainer>
+ <longdescription lang="en">
+ SX Cluster is a reliable, fully distributed cluster solution for your data storage needs, released under the GPL licence. With SX Cluster you aggregate the disk space available on multiple servers and merge it into a single storage system. The cluster makes sure that your data is always replicated over multiple nodes (the exact number of copies is defined by the sysadmin) and synchronized. Additionally Sx has built-in support for deduplication, client-side encryption, on-the-fly compression and much more.
+ </longdescription>
+ <use>
+ <flag name="client">Access the SX Cluster from this machine via its Nginx server. Also responsible for tools required to run the server.</flag>
+ <flag name="ipv6">Enable support for communication via IPv6.</flag>
+ <flag name="server">Enable SX's server component.</flag>
+ <flag name="ssl">Enable communication security via OpenSSL.</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/sx/sx-1.2.ebuild b/net-misc/sx/sx-1.2.ebuild
new file mode 100644
index 000000000000..f24f7a7a7e2f
--- /dev/null
+++ b/net-misc/sx/sx-1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Skylable SX - a distributed object-storage software for data clusters"
+HOMEPAGE="http://www.skylable.com/products/sx"
+SRC_URI="http://cdn.skylable.com/source/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1"
+# If a package appears that links against another .so apart from sxclient-2.0.0.so, change the subslot accordingly.
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="+client ipv6 +server ssl"
+nginx_modules_use="nginx_modules_http_fastcgi(-),nginx_modules_http_gzip(-),nginx_modules_http_proxy(-),nginx_modules_http_scgi(-),nginx_modules_http_uwsgi(-)"
+DEPEND="
+ dev-libs/libltdl:0
+ dev-libs/yajl
+ net-misc/curl[idn,ipv6(-)?,ssh,ssl(-)?]
+ server? ( >=dev-db/sqlite-3.8.4.3:3
+ dev-libs/fcgi
+ www-servers/nginx:mainline[http,ipv6(-)?,${nginx_modules_use},ssl(-)?] )
+"
+RDEPEND="${DEPEND}"
+
+# The server build depends on tools only built during client build.
+# The client, though, is fully functional without server components
+# (for remote access, for example).
+# Deactivate both only if you know you need *only* the libs.
+REQUIRED_USE="server? ( client )"
+
+# tests make a temporary install relative to $prefix, so docdir must be relative to it as well
+src_configure() {
+ econf --disable-sxhttpd \
+ --with-system-libs \
+ --docdir="\${prefix}/usr/share/doc/${PF}" \
+ $(use_enable client sxclient) \
+ $(use_enable server)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --all
+}