summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-05-27 03:31:49 +0800
committerJason Zaman <perfinion@gentoo.org>2017-05-27 03:32:20 +0800
commit7edde5465da4ee83092bed63e95f8bd29f133550 (patch)
tree25fa127dda3c14a7f7b09bbf0f58860a9c1fb5d3 /net-misc
parentapp-office/libreoffice: Fix minimal firebird version (diff)
downloadgentoo-7edde5465da4ee83092bed63e95f8bd29f133550.tar.gz
gentoo-7edde5465da4ee83092bed63e95f8bd29f133550.tar.bz2
gentoo-7edde5465da4ee83092bed63e95f8bd29f133550.zip
net-misc/rclone: New package
Ebuild from Jack Coulter and Chris Pritchard Gentoo-Bug: https://bugs.gentoo.org/609510 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rclone/Manifest1
-rw-r--r--net-misc/rclone/metadata.xml8
-rw-r--r--net-misc/rclone/rclone-1.36.ebuild31
-rw-r--r--net-misc/rclone/rclone-9999.ebuild31
4 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/rclone/Manifest b/net-misc/rclone/Manifest
new file mode 100644
index 000000000000..71ff95857b67
--- /dev/null
+++ b/net-misc/rclone/Manifest
@@ -0,0 +1 @@
+DIST rclone-1.36.tar.gz 14013564 SHA256 a573b70e3aeb355b943dddd6ae9375386fc21bf12dfba601d8d7280f97c4c884 SHA512 589b5e2370244b5609d1ec8245f9f5f5cf58d6a2d507768db2cfc5a5b882f7d277d797fd0068b904538f3700e1751df03a21697d5295c83a2bf01a78d0ac6b13 WHIRLPOOL aa75c6c32cdcebd79ecf79abd03b4dc0205517808eb232a9655e8ae3da327cd62ad7183f4e0b0f6b7b52649c0c5058fdc2b57bc7b31b7dffb05e8a1508307d5c
diff --git a/net-misc/rclone/metadata.xml b/net-misc/rclone/metadata.xml
new file mode 100644
index 000000000000..76f45cdee0f4
--- /dev/null
+++ b/net-misc/rclone/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/rclone/rclone-1.36.ebuild b/net-misc/rclone/rclone-1.36.ebuild
new file mode 100644
index 000000000000..0c936bdca50e
--- /dev/null
+++ b/net-misc/rclone/rclone-1.36.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build
+EGO_PN="github.com/ncw/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+}
diff --git a/net-misc/rclone/rclone-9999.ebuild b/net-misc/rclone/rclone-9999.ebuild
new file mode 100644
index 000000000000..0c936bdca50e
--- /dev/null
+++ b/net-misc/rclone/rclone-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build
+EGO_PN="github.com/ncw/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+}