summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-08-18 17:13:18 +0200
committerJeroen Roovers <jer@gentoo.org>2017-08-18 17:14:00 +0200
commit7f9c7b1152ef3d649924f91b07d345d6d5ebb6bc (patch)
treef57c39c46c2337ed68c718a6fa3718d695c5f6df /net-misc
parentkde-misc/kanyremote: amd64/x86 stable (diff)
downloadgentoo-7f9c7b1152ef3d649924f91b07d345d6d5ebb6bc.tar.gz
gentoo-7f9c7b1152ef3d649924f91b07d345d6d5ebb6bc.tar.bz2
gentoo-7f9c7b1152ef3d649924f91b07d345d6d5ebb6bc.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.08.18.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index ef0312a3a514..185d4d7e7694 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.08.06.tar.gz 2768646 SHA256 95c7e6d7ee9990701c6191223334fce966404b86f7b28e94c570b2c0856aaeed SHA512 605ceda0a6a70ac2cb273b139654a1b42bc8ec02f8973344581aadc9c6bb22019d3ab27406183b5ef430e9f61eba695f507d558b180fbf4bd30f9b81a29b76b2 WHIRLPOOL 2b7505ee3690aab18fc28ce0c08fdeb139151d7feea968d6ac9d94e1a3fe602966f563c6570446442900f0bb19bfb0065bf4d7de27b6ca36a026b4aa7fc6a6a3
DIST youtube-dl-2017.08.13.tar.gz 2777317 SHA256 212c4e6a622d4e20ea888d1b1539ab063e171bed2a05c9e00db71ed53ab059dd SHA512 0063f25b5ee1d1ff750f160d8e2f8c26658045bab5a8f6246ebb004bdef3ff7767034e71931e2e7fcb3e08426265bb7f852330f27beb84586ddeb7871e2bf747 WHIRLPOOL 71d16e1b7ca0996acca808ed79e6b3c0d02569dbda9d0b4e3c2322ca7fcf5a826c16d700df13c487cebf920b3c1f1487d30d5997b4302a62b58712682c7c4b3d
+DIST youtube-dl-2017.08.18.tar.gz 2779312 SHA256 a7f4279b7b8b54f44025fccc22f3e511cae77314f7d37b73334c981946e4c3d6 SHA512 bf403e2f4b7024346219ce01b229ab18329e3faf7aadbd0706e7783072815eaf588812ccbed876212d57192533c09ec8aaceb4a497a411672533b436a9f215f5 WHIRLPOOL a262d999ef27f44b4daeda207b35d2f4952aa04f5b965ada8d47a9b2f64d0f887a5d2276a13db297e9d40957c266556db551ed326beddd5239951cd0262dfc12
diff --git a/net-misc/youtube-dl/youtube-dl-2017.08.18.ebuild b/net-misc/youtube-dl/youtube-dl-2017.08.18.ebuild
new file mode 100644
index 000000000000..57b578450c4e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.08.18.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex motherless myvidster
+ porn91 porncom pornflip pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}