summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-19 03:22:15 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-19 03:22:15 -0400
commit8186945c4b486820e34045b89228b6ce634cfff8 (patch)
tree34cfcbbd7b6d605775d927439741648edea9f990 /net-misc
parentapp-emulation/wine: fix build w/newer glibc #580046 (diff)
downloadgentoo-8186945c4b486820e34045b89228b6ce634cfff8.tar.gz
gentoo-8186945c4b486820e34045b89228b6ce634cfff8.tar.bz2
gentoo-8186945c4b486820e34045b89228b6ce634cfff8.zip
net-misc/chrome-remote-desktop: version bump to 50.0.2661.22
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrome-remote-desktop/Manifest1
-rw-r--r--net-misc/chrome-remote-desktop/chrome-remote-desktop-50.0.2661.22.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-misc/chrome-remote-desktop/Manifest b/net-misc/chrome-remote-desktop/Manifest
index c3600c249ca4..052d43156658 100644
--- a/net-misc/chrome-remote-desktop/Manifest
+++ b/net-misc/chrome-remote-desktop/Manifest
@@ -2,3 +2,4 @@ DIST chrome-remote-desktop_47.0.2526.18_amd64.deb 16611922 SHA256 311bd33e434fae
DIST chrome-remote-desktop_47.0.2526.18_i386.deb 17153928 SHA256 3de83736447f20193d85733d15617befa1adb7a70c0b17c0dd46bcc31b7af414 SHA512 ec03a967c49f092593ec46c8dbf1a72ce7d5b2e63dbaa6d0ea9ea1c0e47ebcbc2aa130ba3135ac6559e3d55b14e77f17568cb72181c86d30f7b64b5666d4c8d6 WHIRLPOOL 032c43af5447bab5a790bf6cb78627573caafceb31de84a3e5024ef25239fb9eb44d44746f1a64d3bc92221cd0c0662b0d511beb8ce538ad162954e9a29456f8
DIST chrome-remote-desktop_49.0.2623.40_amd64.deb 20315570 SHA256 2f3cb883e1ff2465db47d5aadf773efb49c5f11b0bfe3dfba973608e4db45047 SHA512 d936885a986a749a0b4ebb1bb68fe0bc14d10d21363a409abbbb224b4f3ee048ef030ee81469be9bbb8c3852d7c6793fcab1f51d52fcaf5b02cda07550b72330 WHIRLPOOL 6662bfc8a8c298b7c062e4a10752aa3dfe910c7602a0bc20dc64533195d61ceb414dbc411c7f872e085dd13c46372ee46b33904d68bb5aae13698a04442e3905
DIST chrome-remote-desktop_49.0.2623.40_i386.deb 20941574 SHA256 00e480a90b3ed3545ea762d7501b323f2471eb06b11f87882c046598b8f38df7 SHA512 00cf6641ee993fb8c295ca99cb57cde42eb3dd6cc34ae4684f858279615695d5b1a257081e8988293f94e887986492e112bc0276f572cd592d9879dec88eace8 WHIRLPOOL effd2650ee7d5b97f87ede0ac79bc1818ddc06e3eb742a080b12a4ef67283f5ba20495d5a5b4f5a5923d2a9a574a711513344b08abac3938ad142f27af48ed88
+DIST chrome-remote-desktop_50.0.2661.22_amd64.deb 21082544 SHA256 6d17cfee5cf74c98ecbfabbd9b049837c9954495707c2961f8f567afa436e4c5 SHA512 747d0661efbf3957605b0323ad59e7a5c704c45f5da9b32def75723cbe292b5448425871864c126774a8b715e2b57122529f64302df857f1f9bb6bf8eb9eaa6a WHIRLPOOL d160e320d97ecd33cde4e5e86dd8a1f5f3f590ee231a2fbf52a23ff3fa9bb856178a4ae1833ec352b93340a98e4917aea82e33de2a3b9a9f3f188743e9c7d3e1
diff --git a/net-misc/chrome-remote-desktop/chrome-remote-desktop-50.0.2661.22.ebuild b/net-misc/chrome-remote-desktop/chrome-remote-desktop-50.0.2661.22.ebuild
new file mode 100644
index 000000000000..01fc564b9a13
--- /dev/null
+++ b/net-misc/chrome-remote-desktop/chrome-remote-desktop-50.0.2661.22.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Base URL: https://dl.google.com/linux/chrome-remote-desktop/deb/
+# Fetch the Release file:
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/Release
+# Which gives you the Packages file:
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages
+# And finally gives you the file name:
+# pool/main/c/chrome-remote-desktop/chrome-remote-desktop_29.0.1547.32_amd64.deb
+#
+# Use curl to find the answer:
+# curl -q https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages | grep ^Filename
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit unpacker eutils python-single-r1
+
+DESCRIPTION="access remote computers via Chrome!"
+PLUGIN_URL="https://chrome.google.com/remotedesktop"
+HOMEPAGE="https://support.google.com/chrome/answer/1649523 ${PLUGIN_URL}"
+BASE_URI="https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/${PN}/${PN}_${PV}"
+SRC_URI="amd64? ( ${BASE_URI}_amd64.deb )"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+# All the libs this package links against.
+RDEPEND="app-admin/sudo
+ ${PYTHON_DEPS}
+ >=dev-libs/expat-2
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/psutil
+ gnome-base/gconf:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-libs/pam
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ x11-libs/pango"
+# Settings we just need at runtime.
+RDEPEND+="
+ x11-base/xorg-server[xvfb]"
+DEPEND=""
+
+S=${WORKDIR}
+
+QA_PREBUILT="/opt/google/chrome-remote-desktop/*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-44.0.2403.44-always-sudo.patch #541708
+ python_fix_shebang opt/google/chrome-remote-desktop/chrome-remote-desktop
+}
+
+src_install() {
+ insinto /etc
+ doins -r etc/opt
+
+ insinto /opt
+ doins -r opt/google
+ chmod a+rx "${ED}"/opt/google/${PN}/* || die
+
+ dodir /etc/pam.d
+ dosym system-remote-login /etc/pam.d/${PN}
+
+ dodoc usr/share/doc/${PN}/changelog*
+
+ newinitd "${FILESDIR}"/${PN}.rc ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Two ways to launch the server:"
+ elog "(1) access an existing desktop"
+ elog " (a) install the Chrome plugin on the server & client:"
+ elog " ${PLUGIN_URL}"
+ elog " (b) on the server, run the Chrome plugin & enable remote access"
+ elog " (c) on the client, connect to the server"
+ elog "(2) headless system"
+ elog " (a) install the Chrome plugin on the client:"
+ elog " ${PLUGIN_URL}"
+ elog " (b) visit https://accounts.google.com/o/oauth2/auth?response_type=code&scope=https://www.googleapis.com/auth/chromoting+https://www.googleapis.com/auth/googletalk+https://www.googleapis.com/auth/userinfo.email&access_type=offline&redirect_uri=https://chromoting-auth.googleplex.com/auth&approval_prompt=force&client_id=440925447803-avn2sj1kc099s0r7v62je5s339mu0am1.apps.googleusercontent.com&hl=en&from_login=1&as=-760f476eeaec11b8&pli=1&authuser=0"
+ elog " (c) run the command mentioned on the server"
+ elog " (d) on the client, connect to the server"
+ elog
+ elog "Configuration settings you might want to be aware of:"
+ elog " ~/.${PN}-session - shell script to start your session"
+ elog " /etc/init.d/${PN} - script to auto-restart server"
+ fi
+}