summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-03-14 23:09:33 +0100
committerMatthew Brewer <tomboy64@sina.cn>2016-03-14 23:13:02 +0100
commit9355e04513bb43dc83b0875d97d5e5c0180fcb95 (patch)
tree1815f4f1814a1a32d8f2ef570b652fe31d02e8a3 /net-misc
parentx11-drivers/xf86-video-intel: Fix kernel check (diff)
downloadgentoo-9355e04513bb43dc83b0875d97d5e5c0180fcb95.tar.gz
gentoo-9355e04513bb43dc83b0875d97d5e5c0180fcb95.tar.bz2
gentoo-9355e04513bb43dc83b0875d97d5e5c0180fcb95.zip
net-misc/libres3: version bump to 1.2
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/libres3/Manifest1
-rw-r--r--net-misc/libres3/libres3-1.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/libres3/Manifest b/net-misc/libres3/Manifest
index b18552b756f1..cae74160e488 100644
--- a/net-misc/libres3/Manifest
+++ b/net-misc/libres3/Manifest
@@ -1 +1,2 @@
DIST libres3-1.1.tar.gz 7025033 SHA256 d4b3199db31844811290e8e9674bccd82c05e204537c499ac7d10d385b1cea13 SHA512 cdbefef90076f9f94f3b1635639a4b64e7666532ae6f51434d344e5c4ef1d4dce2787c52903ee5f0d6630ff84d8e79e14c843ac84d9e1affd2c1f16a41ffcfa3 WHIRLPOOL 015f7af705a58a21e8392661ca3ac9c0373803f4b588140af27f2d7706a8e0948fffeed26201ee9bd58f8e71bc0cde4557aaedbfc54f769c9564ebf7c6115a8d
+DIST libres3-1.2.tar.gz 7112430 SHA256 d903196a3b9e0e65b67ba140f3fc1a8ef9f9c37b3c72389ba14ff0d3a40e3cd8 SHA512 4ea854abdaf5d6ca6ecb0bedd55af93a676ec465f30747a9e63e33dc145bbe17b466d394d784c420babe1b147076711ef99bf28f89ab3cc546a373cb72ede1fd WHIRLPOOL de955534136f9246417c3b56a8d0de186fa77f838e1b3708d3db22514f7ae0fac3bf3aee8a32691fbfe05f43814bdd353eba7766861dcdede22a5d15834ac3ef
diff --git a/net-misc/libres3/libres3-1.2.ebuild b/net-misc/libres3/libres3-1.2.ebuild
new file mode 100644
index 000000000000..6ce3881be5fc
--- /dev/null
+++ b/net-misc/libres3/libres3-1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+inherit oasis findlib
+
+DESCRIPTION="Skylable LibreS3 - Amazon S3 open source replacement"
+HOMEPAGE="http://www.skylable.com/products/libres3"
+SRC_URI="http://cdn.skylable.com/source/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+OASIS_DOC_DIR="/usr/share/doc/${PF}"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/camlp4:=
+ dev-ml/jsonm:=
+ dev-ml/lwt:=[react,ssl]
+ dev-ml/ocaml-base64:=
+ dev-ml/ocaml-dns:=[lwt(-)]
+ dev-ml/ocaml-ipaddr:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocaml-ssl:=
+ >=dev-ml/ocamlnet-3.7.4:=[pcre]
+ <dev-ml/ocamlnet-4:=[pcre]
+ dev-ml/optcomp:=
+ dev-ml/ounit:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/tyxml:=
+ dev-ml/uutf:=
+ dev-ml/xmlm:=
+ www-servers/ocsigenserver:=[sqlite]
+"
+DEPEND="
+ dev-ml/oasis
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+S="${WORKDIR}/${P}/libres3"
+
+src_prepare() {
+ sed -e '/..\/..\/COPYING/d' -i _oasis || die
+ rm setup.ml || die
+ emake update
+}
+
+src_configure() {
+ oasis_configure_opts="
+ --sysconfdir ${EPREFIX}/etc/${PN}
+ --localstatedir ${EPREFIX}/var" oasis_src_configure
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if [[ -d /etc/logrotate.d ]]; then
+ insinto /etc/logrotate.d
+ doins src/files/conf/logrotate.d/libres3
+ fi
+}
+
+pkg_postinst() {
+ elog "*******************************************************************************"
+ elog "Just as a heads-up: LibreS3 requires a working SX cluster (net-misc/sx) to be"
+ elog "of any use. Since LibreS3 is capable of connecting to a remote SX cluster it"
+ elog "doesn't depend on it. Hence you will likely want to install it."
+ elog ""
+ elog "Standard S3 client libraries and tools (for example s3cmd, python-boto,"
+ elog "ocaml-aws, etc.) can be used to access it."
+ elog "Enjoy."
+ elog "*******************************************************************************"
+}