summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-02 21:02:35 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-02 21:28:43 +0100
commit99dcfc7543033fa4f17cbb1f89e858e4e1ba5ee7 (patch)
tree6926381ed5ddfd4463be97c028c75ceecd9a1221 /net-misc
parentnet-wireless/urh: version bump and no more automagic deps, thanks upstream :-) (diff)
downloadgentoo-99dcfc7543033fa4f17cbb1f89e858e4e1ba5ee7.tar.gz
gentoo-99dcfc7543033fa4f17cbb1f89e858e4e1ba5ee7.tar.bz2
gentoo-99dcfc7543033fa4f17cbb1f89e858e4e1ba5ee7.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.03.02.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index b7f892569f16..b3474fd356cb 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.12.22.tar.gz 2502964 SHA256 f5bc5eb1af17391b7a1da795f4181c3702fb2c1da2668b25f1260dbdba882524 SHA512 87fee134da660a4feb4cfcd2cbb35cb9682e6ed08c766e3c89f6c986f991cac78c64f5bf8a1d15c4080e4df0909c6a360137407a7896b93f8f41cf4493f341cb WHIRLPOOL 6909d34958e4152be3334723c68d207bb34db2996d90908829ebd3ee45d28768d7f6cba8ce0fb19de440b34fb96b46b3d5b8bf830c998037c4f4d59e574206c3
DIST youtube-dl-2017.02.22.tar.gz 2599204 SHA256 51f45723f1e39eb2c780bf1b490ec9150efdac9db86d3010f8fcc53400c87129 SHA512 69372a1df4ffe9454fde3710d3dbca34dca1f2bd8f1af8b06dd89245a28efd6fbca8e680cbda990db589e6ff7d8e753d8e4202d7565e3b2b8bd4205dcaf23c09 WHIRLPOOL 8bcb51d115a5b6f4ff2ea716192b5ab9d3ac7ee7804d08e1870d1cba41f8ea8ee9a2224a942776a79b19725ab1525eabf249a6acfaf9aaf7da337f33d1f3f0a8
DIST youtube-dl-2017.02.28.tar.gz 2615247 SHA256 495aad98ae067b0edeb532c4ab5cdb9cfe9c7871b12e632f6df3c32934ba96a4 SHA512 062a80e819324144a61fe795400d2adbe92d3b47b1b2562dba377ecfecbaa1583fd4ed4f8b3075aaea0ab8dfb5c92fd987c9f910a2a277d49e06b876541d0ec0 WHIRLPOOL 50c98001971b1e65343fa317bca404f2171c71ed5287353253e709bca658d8bd4e7e0de5d8c43a81e9488b959566c6e74dac8089a5f12360fae909de6dee7e38
+DIST youtube-dl-2017.03.02.tar.gz 2616400 SHA256 2f010132da4cc3e67582f89eff9bc4bb4c0e7b60c0ddba101370d97eafc50639 SHA512 2239948aa3a513956a161c6eaf58c0e0e2272a15a7cfb8efd141501a49f215860f87365cfeea6422b82612209005e9a635ca3cc3822e1222a8b09b1da727d6ac WHIRLPOOL b8d5c1d3a13392df52426149385ff4b43670706c2abc49d1c91490a130c40f93fe752ef3283fc89fe3b740a3d3d511506e2e067c08e9f35925c4eece54e98eb8
diff --git a/net-misc/youtube-dl/youtube-dl-2017.03.02.ebuild b/net-misc/youtube-dl/youtube-dl-2017.03.02.ebuild
new file mode 100644
index 000000000000..a8678ca1fa91
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.03.02.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}