summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-08-26 15:14:51 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-09-01 08:03:26 -0400
commit9cda9319b481c907542049d6b89b2917f02e3e3f (patch)
tree680c2549090cc4bdbbf6e5ab80d32288480ba419 /net-misc
parentdev-libs/opensc: add 0.22.0 (diff)
downloadgentoo-9cda9319b481c907542049d6b89b2917f02e3e3f.tar.gz
gentoo-9cda9319b481c907542049d6b89b2917f02e3e3f.tar.bz2
gentoo-9cda9319b481c907542049d6b89b2917f02e3e3f.zip
net-misc/gns3-server: version bump (2.2.24)
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/809278 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gns3-server/Manifest1
-rw-r--r--net-misc/gns3-server/files/gns3-server-2.2.24-Fix-tests.patch73
-rw-r--r--net-misc/gns3-server/gns3-server-2.2.24.ebuild76
3 files changed, 150 insertions, 0 deletions
diff --git a/net-misc/gns3-server/Manifest b/net-misc/gns3-server/Manifest
index 9661f43132d9..7218793a65b5 100644
--- a/net-misc/gns3-server/Manifest
+++ b/net-misc/gns3-server/Manifest
@@ -1,2 +1,3 @@
DIST gns3-server-2.2.21.tar.gz 9054117 BLAKE2B dbbbba4dfe8d084184d38750c67152b99ee286dae88d92c15f153077396cdb008214da89d9161516daef0fbde8de3ba30f6628b9d138799d9ed8c1bc21c17f29 SHA512 adb7b08c88525f8b292688cd31973a00723b8d7989399d861e629bf754408901c2b00c67d425aacd7c234d9bab5d46542024196a4b44066eb1dbf39cf3d521bb
DIST gns3-server-2.2.22.tar.gz 9011028 BLAKE2B 910711cac6f649d8dd3f7a4d2a9aa77839c9dda9f4280e7079b86857c542907feaa1205b7060ce7cc8956a2fbd220d5393cda319f64ff17eeb5ce476922afccc SHA512 444f483e69a56ab82c053c042b8791711e2fc6b7c800d30c08f2221405418a5c78d780f0f959c80d56ce864230ae17b04639c74a6559c7f5abce65f9c808a282
+DIST gns3-server-2.2.24.tar.gz 9057352 BLAKE2B cc49127afa9b3422f25ec2d10e53b7cedc59a4b872394d7b7c47ac34e6859fd5f22547277f351ba75b6520a0881b2ebbda6ba932af31108f070c2ccd92574020 SHA512 22a4394f645b5909e75b07d63164ad4fa362f78d69c6f30e8e2daf15bc910c238e8cd983a9f1cb3c1045a0722f9a1c260002b4afe8fb5915033b3ddb20814a17
diff --git a/net-misc/gns3-server/files/gns3-server-2.2.24-Fix-tests.patch b/net-misc/gns3-server/files/gns3-server-2.2.24-Fix-tests.patch
new file mode 100644
index 000000000000..3d0556ab4a1c
--- /dev/null
+++ b/net-misc/gns3-server/files/gns3-server-2.2.24-Fix-tests.patch
@@ -0,0 +1,73 @@
+From 4eb8491cfa61310066395f078009ccc822488eb8 Mon Sep 17 00:00:00 2001
+From: grossmj <grossmj@gns3.net>
+Date: Wed, 1 Sep 2021 19:31:37 +0930
+Subject: [PATCH] Fix tests. Fixes #1950
+
+---
+ tests/compute/qemu/test_qemu_manager.py | 1 -
+ tests/compute/qemu/test_qemu_vm.py | 12 ++++++------
+ tests/compute/test_manager.py | 2 +-
+ 3 files changed, 7 insertions(+), 8 deletions(-)
+
+--- a/tests/compute/qemu/test_qemu_manager.py
++++ b/tests/compute/qemu/test_qemu_manager.py
+@@ -71,7 +71,6 @@ async def test_binary_list(monkeypatch, tmpdir):
+ assert {"path": os.path.join(os.environ["PATH"], "qemu-kvm"), "version": version} in qemus
+ assert {"path": os.path.join(os.environ["PATH"], "qemu-system-x42"), "version": version} in qemus
+ assert {"path": os.path.join(os.environ["PATH"], "hello"), "version": version} not in qemus
+- assert {"path": os.path.join(os.environ["PATH"], "qemu-system-x86_64-spice"), "version": version} not in qemus
+
+ qemus = await Qemu.binary_list(["x86"])
+
+--- a/tests/compute/qemu/test_qemu_vm.py
++++ b/tests/compute/qemu/test_qemu_vm.py
+@@ -818,21 +818,21 @@ def test_options(linux_platform, vm):
+ assert vm.kvm is False
+
+ vm.options = "-no-kvm"
+- assert vm.options == "-no-kvm"
++ assert vm.options == "-machine accel=tcg"
+
+ vm.options = "-enable-kvm"
+- assert vm.options == "-enable-kvm"
++ assert vm.options == "-machine accel=kvm"
+
+ vm.options = "-icount 12"
+- assert vm.options == "-no-kvm -icount 12"
++ assert vm.options == "-icount 12"
+
+ vm.options = "-icount 12 -no-kvm"
+- assert vm.options == "-icount 12 -no-kvm"
++ assert vm.options == "-icount 12 -machine accel=tcg"
+
+
+ def test_options_windows(windows_platform, vm):
+ vm.options = "-no-kvm"
+- assert vm.options == ""
++ assert vm.options == "-machine accel=tcg"
+
+ vm.options = "-enable-kvm"
+ assert vm.options == ""
+@@ -878,7 +878,7 @@ async def test_run_with_kvm_linux_options_no_kvm(linux_platform, vm):
+
+ with patch("os.path.exists", return_value=True) as os_path:
+ vm.manager.config.set("Qemu", "enable_kvm", True)
+- assert await vm._run_with_hardware_acceleration("qemu-system-x86_64", "-no-kvm") is False
++ assert await vm._run_with_hardware_acceleration("qemu-system-x86_64", "-machine accel=tcg") is False
+
+
+ async def test_run_with_kvm_not_x86(linux_platform, vm):
+--- a/tests/compute/test_manager.py
++++ b/tests/compute/test_manager.py
+@@ -190,7 +190,7 @@ def test_get_abs_image_recursive_ova(qemu, tmpdir, config):
+ config.set_section_config("Server", {
+ "images_path": str(tmpdir / "images1"),
+ "local": False})
+- assert qemu.get_abs_image_path("test.ova/test1.bin") == path1
++ assert qemu.get_abs_image_path("demo/test.ova/test1.bin") == path1
+ assert qemu.get_abs_image_path("test.ova/test2.bin") == path2
+ # Absolute path
+ assert qemu.get_abs_image_path(str(path1)) == path1
+--
+2.33.0
+
diff --git a/net-misc/gns3-server/gns3-server-2.2.24.ebuild b/net-misc/gns3-server/gns3-server-2.2.24.ebuild
new file mode 100644
index 000000000000..78581b451547
--- /dev/null
+++ b/net-misc/gns3-server/gns3-server-2.2.24.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature systemd
+
+DESCRIPTION="GNS3 server to asynchronously manage emulators"
+HOMEPAGE="https://www.gns3.com/ https://github.com/GNS3/gns3-server"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emulation/dynamips
+ >=dev-python/aiofiles-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-cors-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/async_timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.7.0[${PYTHON_USEDEP}]
+ >=dev-python/py-cpuinfo-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sentry-sdk-1.3.1[${PYTHON_USEDEP}]
+ net-misc/ubridge
+ sys-apps/busybox
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-Fix-tests.patch )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # newer python packages are fine
+ sed -i -e 's/[<>=].*//' requirements.txt || die
+
+ # Remove Pre-built busybox binary
+ rm gns3server/compute/docker/resources/bin/busybox || die
+
+ # add setuptools dependency, bug #809278
+ echo setuptools >> requirements.txt || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ systemd_dounit init/gns3.service.systemd
+
+ mkdir -p "${D}$(python_get_sitedir)/gns3server/compute/docker/resources/bin" || die
+ ln -s /bin/busybox "${D}$(python_get_sitedir)/gns3server/compute/docker/resources/bin/busybox" || die
+}
+
+pkg_postinst() {
+ elog "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
+ elog ""
+ optfeature "QEMU Support" "app-emulation/qemu"
+ optfeature "Virtualbox Support" "app-emulation/virtualbox"
+ optfeature "Docker Support" "app-emulation/docker"
+ optfeature "Wireshark Support" "net-analyzer/wireshark"
+ elog ""
+ elog "The following packages are currently unsupported:"
+ elog "iouyap and vpcs"
+}