summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-04-18 12:39:56 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-04-18 12:40:46 -0500
commitb8c29394a688ed4389a6826583a0632eb8fc6328 (patch)
treeb33fd7dc9dbc900903c44a4ddf43747fd7d1a86f /net-misc
parentsys-apps/smartmontools: Keep temporarily empty /var/db/smartmontools directory. (diff)
downloadgentoo-b8c29394a688ed4389a6826583a0632eb8fc6328.tar.gz
gentoo-b8c29394a688ed4389a6826583a0632eb8fc6328.tar.bz2
gentoo-b8c29394a688ed4389a6826583a0632eb8fc6328.zip
net-misc/dhcpcd: add patch to fix compile issue for bug #579854
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/dhcpcd-6.10.2.ebuild4
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-6.10.2-fix-configure.patch45
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-6.10.2.ebuild b/net-misc/dhcpcd/dhcpcd-6.10.2.ebuild
index 0b616f0955c5..cdd7e07bc2b3 100644
--- a/net-misc/dhcpcd/dhcpcd-6.10.2.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-6.10.2.ebuild
@@ -27,6 +27,10 @@ COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
+PATCHES=(
+"${FILESDIR}"/${P}-fix-configure.patch
+)
+
if [[ ${PV} == "9999" ]]; then
DEPEND+=" dev-vcs/fossil"
diff --git a/net-misc/dhcpcd/files/dhcpcd-6.10.2-fix-configure.patch b/net-misc/dhcpcd/files/dhcpcd-6.10.2-fix-configure.patch
new file mode 100644
index 000000000000..97cc2fac2b41
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-6.10.2-fix-configure.patch
@@ -0,0 +1,45 @@
+Index: configure
+==================================================================
+--- a/configure
++++ b/configure
+@@ -360,19 +360,10 @@
+ esac
+ else
+ echo "CPPFLAGS+= -DNDEBUG" >>$CONFIG_MK
+ fi
+
+-if [ -z "$EMBEDDED" -o "$EMBEDDED" = yes ]; then
+- echo "dhcpcd-definitions.conf will be embedded in dhcpcd itself"
+- echo "DHCPCD_SRCS+= dhcpcd-embedded.c" >>$CONFIG_MK
+-else
+- echo "dhcpcd-definitions.conf will be installed to $LIBEXECDIR"
+- echo "CFLAGS+= -DEMBEDDED_CONFIG=\\\"$LIBEXECDIR/dhcpcd-definitions.conf\\\"" >>$CONFIG_MK
+- echo "EMBEDDEDINSTALL= _embeddedinstall" >>$CONFIG_MK
+-fi
+-
+ if [ -n "$FORK" -a "$FORK" != yes -a "$FORK" != true ]; then
+ echo "There is no fork"
+ echo "CPPFLAGS+= -DTHERE_IS_NO_FORK" >>$CONFIG_MK
+ fi
+
+@@ -460,10 +451,19 @@
+ echo "$CC does not create executables" >&2
+ exit 1
+ fi
+ [ "$CC" != cc ] && echo "CC= $CC" >>$CONFIG_MK
+ $CC --version | $SED -e '1!d'
++
++if [ -z "$EMBEDDED" -o "$EMBEDDED" = yes ]; then
++ echo "dhcpcd-definitions.conf will be embedded in dhcpcd itself"
++ echo "DHCPCD_SRCS+= dhcpcd-embedded.c" >>$CONFIG_MK
++else
++ echo "dhcpcd-definitions.conf will be installed to $LIBEXECDIR"
++ echo "CPPFLAGS+= -DEMBEDDED_CONFIG=\\\"$LIBEXECDIR/dhcpcd-definitions.conf\\\"" >>$CONFIG_MK
++ echo "EMBEDDEDINSTALL= _embeddedinstall" >>$CONFIG_MK
++fi
+
+ if [ "$OS" = linux ]; then
+ printf "Testing for nl80211 ... "
+ cat <<EOF >_nl80211.c
+ #include <linux/nl80211.h>
+