summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-04 23:23:58 +0100
committerSam James <sam@gentoo.org>2022-08-04 23:25:46 +0100
commitbddd4dc11594de118a88e70fd4e7af7526364c00 (patch)
tree89f1fcf124f077bb6468e6622bfab0eb0518c9f3 /net-misc
parentnet-misc/htpdate: update upstream metadata (diff)
downloadgentoo-bddd4dc11594de118a88e70fd4e7af7526364c00.tar.gz
gentoo-bddd4dc11594de118a88e70fd4e7af7526364c00.tar.bz2
gentoo-bddd4dc11594de118a88e70fd4e7af7526364c00.zip
net-misc/htpdate: add 1.3.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/htpdate/Manifest1
-rw-r--r--net-misc/htpdate/htpdate-1.3.5.ebuild55
-rw-r--r--net-misc/htpdate/htpdate-9999.ebuild13
3 files changed, 63 insertions, 6 deletions
diff --git a/net-misc/htpdate/Manifest b/net-misc/htpdate/Manifest
index 019b6469ab48..fb787ddeba51 100644
--- a/net-misc/htpdate/Manifest
+++ b/net-misc/htpdate/Manifest
@@ -1,3 +1,4 @@
DIST htpdate-1.2.2.tar.gz 13625 BLAKE2B 11813def81e3cce1194120a21cf99e8ad288b0f604aab201850f03b6ca786d19792b9586c9d805aa1945bbc651e6afc5099b5c7cb6ea354473a4b3bab01397e3 SHA512 00d52b291004ddb3d0282aef78c5fbe5d9397dbf171a6646803ee7ba4bd0514af6089f7e48a92397dd1b0fbae5ba314f5165c9902028438e16d3516b65724de0
DIST htpdate-1.3.3.tar.gz 16302 BLAKE2B eb19462e1e5d02fe3cda7f4d2c954e2fe4b8dfcc299dc9094466a8652250ce27d37b2cf85716435639580e48295a92ad65521e0420cecac875c9b6e8074d425a SHA512 5d4892ea3626b80e5d529de873f675616dfef156e91d1e574225f91f9496503f55da43aa4f3522cb2b55da7c41dba7d97b3cc557a2704945577ec0243d8bd7f8
DIST htpdate-1.3.4.tar.gz 16312 BLAKE2B 9ebff6df6de69fa310a6459099cff2bf5ec28ac2bb486a29121b87b93505f6bb31b4debc510dc82b7d7b7cce217d9002ec7606fcf4fa863d7b2cfc78dfc6e8d5 SHA512 634317966f1e5c5d78a889a398e77f89505a5918efa076e2cd1184341f25d963b7f1c135afee7d5489bd8a20b2421d9dfea312e09b5e6bdd389626bfd4d2d960
+DIST htpdate-1.3.5.tar.gz 16661 BLAKE2B 063e5c46b86b6f99a500ff2054110b37157c11bd09b20db06d845b632a0e4d954f2f5cf8fd935f8fd8a69f0e64e0f3db1cb734fa24a77bf2b07855dd3fad9a3c SHA512 db1d237588e44e6eb113d046be2f68b5fac96cc7dc54b4522e1b61ca20a0ea3674265db03796fd6442fab58b82273e6a81ae3914c6d531e03f4fc5f65a3507e3
diff --git a/net-misc/htpdate/htpdate-1.3.5.ebuild b/net-misc/htpdate/htpdate-1.3.5.ebuild
new file mode 100644
index 000000000000..51cf1b0a1728
--- /dev/null
+++ b/net-misc/htpdate/htpdate-1.3.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 toolchain-funcs
+
+DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
+HOMEPAGE="https://www.vervest.org/htp/"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/twekkel/htpdate"
+else
+ SRC_URI="https://github.com/twekkel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+# Test suite tries to connect to the Internet
+RESTRICT="test"
+
+DOC_CONTENTS="If you would like to run htpdate as a daemon, set
+appropriate http servers in /etc/conf.d/htpdate!"
+
+src_prepare() {
+ default
+
+ # Use more standard adjtimex() to fix uClibc builds.
+ sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
+ # Don't compress man pages by default
+ sed '/gzip/d' -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="-Wall ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ $(usev ssl 'https')
+}
+
+src_install() {
+ emake DESTDIR="${D}" STRIP="/bin/true" bindir='$(prefix)/sbin' install
+ dodoc README.md Changelog
+
+ newconfd "${FILESDIR}"/htpdate.conf htpdate
+ newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
+
+ readme.gentoo_create_doc
+}
diff --git a/net-misc/htpdate/htpdate-9999.ebuild b/net-misc/htpdate/htpdate-9999.ebuild
index 31e1a7d493bf..51cf1b0a1728 100644
--- a/net-misc/htpdate/htpdate-9999.ebuild
+++ b/net-misc/htpdate/htpdate-9999.ebuild
@@ -7,16 +7,17 @@ inherit readme.gentoo-r1 toolchain-funcs
DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
HOMEPAGE="https://www.vervest.org/htp/"
-if [[ "${PV}" == *9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/twekkel/htpdate"
else
SRC_URI="https://github.com/twekkel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
fi
-IUSE="+ssl"
+
LICENSE="GPL-2"
SLOT="0"
+IUSE="+ssl"
DEPEND="ssl? ( dev-libs/openssl:0= )"
RDEPEND="${DEPEND}"
@@ -27,8 +28,6 @@ RESTRICT="test"
DOC_CONTENTS="If you would like to run htpdate as a daemon, set
appropriate http servers in /etc/conf.d/htpdate!"
-PATCHES=( )
-
src_prepare() {
default
@@ -39,8 +38,10 @@ src_prepare() {
}
src_compile() {
- emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
- $(usex ssl "https" '')
+ emake \
+ CFLAGS="-Wall ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ $(usev ssl 'https')
}
src_install() {