summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-02-21 14:18:27 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-02-21 14:18:49 +0000
commitc8905a00654e1e7c9f0a109875519a753696cec8 (patch)
tree03d9f5a45cc3938a45cabb14cc528dc2357339c2 /net-misc
parentdev-perl/POE: Version bump. Add IO::Pipely dependency. Fixes bug 569604. (diff)
downloadgentoo-c8905a00654e1e7c9f0a109875519a753696cec8.tar.gz
gentoo-c8905a00654e1e7c9f0a109875519a753696cec8.tar.bz2
gentoo-c8905a00654e1e7c9f0a109875519a753696cec8.zip
net-misc/r8168: Linux 4.5 fix and EAPI bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/r8168/r8168-8.041.00-r1.ebuild (renamed from net-misc/r8168/r8168-8.041.00.ebuild)16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-misc/r8168/r8168-8.041.00.ebuild b/net-misc/r8168/r8168-8.041.00-r1.ebuild
index 382e7b036143..b32b2e2e9ab6 100644
--- a/net-misc/r8168/r8168-8.041.00.ebuild
+++ b/net-misc/r8168/r8168-8.041.00-r1.ebuild
@@ -1,18 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit linux-mod eutils
+inherit linux-info linux-mod eutils
DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
HOMEPAGE="http://www.realtek.com.tw"
SRC_URI="http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0003-${P}.tar.bz2 -> ${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
KEYWORDS="~amd64 ~x86"
MODULE_NAMES="r8168(net:${S}/src)"
@@ -26,6 +24,14 @@ pkg_setup() {
BUILD_PARAMS="KERNELDIR=${KV_DIR}"
}
+src_prepare() {
+ default
+
+ if kernel_is -ge 4 5; then
+ sed -i 's/NETIF_F_ALL_CSUM/NETIF_F_CSUM_MASK/g' src/r8168_n.c || die
+ fi
+}
+
src_install() {
linux-mod_src_install
dodoc README