summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-12 00:42:50 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-12 00:42:50 +0100
commitcddcbd4db4dfd760cbf34ea8ea10b30392820ff5 (patch)
treed4b5656230ce748b9bd217686777c35be2ec287c /net-misc
parentapp-emulation/spice-vdagent: Fix underlinking with GCC 5 (diff)
downloadgentoo-cddcbd4db4dfd760cbf34ea8ea10b30392820ff5.tar.gz
gentoo-cddcbd4db4dfd760cbf34ea8ea10b30392820ff5.tar.bz2
gentoo-cddcbd4db4dfd760cbf34ea8ea10b30392820ff5.zip
net-misc/htun: Fix multiple symbol definitions
Gentoo-bug: 571458 * EAPI=6 * Made PATCHES -p1 compliant * Respect CFLAGS Package-Manager: portage-2.3.3
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/htun/files/htun-0.9.6-glibc.patch4
-rw-r--r--net-misc/htun/files/htun-0.9.6-makefile.patch18
-rw-r--r--net-misc/htun/htun-0.9.6.ebuild23
3 files changed, 32 insertions, 13 deletions
diff --git a/net-misc/htun/files/htun-0.9.6-glibc.patch b/net-misc/htun/files/htun-0.9.6-glibc.patch
index 66f9b5ba00a5..3f281c526388 100644
--- a/net-misc/htun/files/htun-0.9.6-glibc.patch
+++ b/net-misc/htun/files/htun-0.9.6-glibc.patch
@@ -2,8 +2,8 @@ get things building with glibc-2.8
http://bugs.gentoo.org/248100
---- include/common.h
-+++ include/common.h
+--- a/include/common.h
++++ b/include/common.h
@@ -23,6 +23,7 @@
#ifndef __COMMON_H
#define __COMMON_H
diff --git a/net-misc/htun/files/htun-0.9.6-makefile.patch b/net-misc/htun/files/htun-0.9.6-makefile.patch
index 0a94966802d8..c1f0b76bfa14 100644
--- a/net-misc/htun/files/htun-0.9.6-makefile.patch
+++ b/net-misc/htun/files/htun-0.9.6-makefile.patch
@@ -1,8 +1,11 @@
---- src/Makefile 2005-10-27 12:58:53.000000000 +0200
-+++ src/Makefile 2013-03-08 22:20:52.360922189 +0100
+* Fix build system to not hardcode CC
+* Fix build system to respect user flags
+
+--- a/src/Makefile
++++ b/src/Makefile
@@ -20,16 +20,14 @@
- # $Id$
+ # $Id: Makefile,v 2.16 2002/08/11 15:57:07 jehsom Exp $
-
-CFLAGS = -I../include -I. -O -W -Wall -g -D_REENTRANT #-pg -a
@@ -20,3 +23,12 @@
LEX = flex
YACC = yacc
INCLUDE := $(wildcard ../include/*.h)
+@@ -52,7 +50,7 @@
+ $(OBJS): $(INCLUDE)
+
+ $(CONFOBS): $(CONFSRC)
+- $(CC) $(LEX_CFLAGS) -c $(@:.o=.c)
++ $(CC) $(CFLAGS) $(LEX_CFLAGS) -c $(@:.o=.c)
+
+ lex.yy.c: parse.l
+ $(LEX) $^
diff --git a/net-misc/htun/htun-0.9.6.ebuild b/net-misc/htun/htun-0.9.6.ebuild
index e5ffb4446aa3..0de19a58d73f 100644
--- a/net-misc/htun/htun-0.9.6.ebuild
+++ b/net-misc/htun/htun-0.9.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-inherit eutils readme.gentoo
+inherit flag-o-matic readme.gentoo-r1 toolchain-funcs
DESCRIPTION="Project to tunnel IP traffic over HTTP"
HOMEPAGE="http://linux.softpedia.com/get/System/Networking/HTun-14751.shtml"
@@ -19,11 +19,15 @@ KEYWORDS="~amd64 ~x86"
DEPEND="dev-util/yacc"
RDEPEND=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-glibc.patch #248100
- epatch "${FILESDIR}"/${P}-makefile.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc.patch #248100
+ "${FILESDIR}"/${P}-makefile.patch
+)
- epatch_user
+src_configure() {
+ # Fix multiple symbol definitions due to
+ # C99/C11 inline semantics, bug 571458
+ append-cflags -std=gnu89
}
src_compile() {
@@ -32,8 +36,11 @@ src_compile() {
src_install() {
dosbin src/htund
+
insinto /etc
doins doc/htund.conf
- dodoc doc/* README
+
+ local DOCS=( doc/. README )
+ einstalldocs
readme.gentoo_create_doc
}