summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-28 23:00:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-28 23:03:07 +0200
commitce6c054200b64ef3c19251efd8236e915cd99d5b (patch)
treebf299779bc92c0d2f8fd59b2e50a928a9509627e /net-misc
parentapp-admin/salt: remove unused patch (diff)
downloadgentoo-ce6c054200b64ef3c19251efd8236e915cd99d5b.tar.gz
gentoo-ce6c054200b64ef3c19251efd8236e915cd99d5b.tar.bz2
gentoo-ce6c054200b64ef3c19251efd8236e915cd99d5b.zip
net-misc/gallery-dl: bump to 1.22.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.22.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 44c9aeb9909b..c890a0fc0ea4 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -2,3 +2,4 @@ DIST gallery-dl-1.21.1.tar.gz 432380 BLAKE2B 58267dad8af16cb8b03bc7532e934e15c51
DIST gallery-dl-1.21.2.tar.gz 434114 BLAKE2B 2f1335d0745c3fd3de95f9f3005fc67f079fec16925b7ac8fb3f2e9c8521139e56bf18675e15e7e0edbad2889cd7fa895552e8b40d9f1cf6bc555894c8d1da48 SHA512 11615ebb3cab5a6d9e042a94cf802f3781af6166eb199ac22f70a0d3351299bdc82dda212a3a363c323e0edb6707355fe9b6f3d89a851037a8f6ebc12894558f
DIST gallery-dl-1.22.1.tar.gz 459120 BLAKE2B 2a3fcfcd10f9446ffdbcb44b920bbf962befcf8c338f7b48447d541e9f1c32a42ae7ac50b578fe8bce6039f3556d55d1fb0161689e0efbea6af9586668f4f488 SHA512 a277f70003603631a17081703fa1003791b106500422dabb406d20aaa80c71dcf3bfa8697ae8436025184e1a7115378a71b2a7e61eaa6b85195b4a3e5ba08ea6
DIST gallery-dl-1.22.2.gh.tar.gz 463977 BLAKE2B f84837eaa0bdeccf7a63267c08657dc2fcbb17c218a10ed4b16d8b086f4aabca6097cb4161058b76796e96fa5fc57c8cde2a2f0387a28413cc6b6eab7a3f429b SHA512 b3a9790beed25a362a573b33dfaa18739072503d264044953b97e661e22c4850bfff04803e65f39b6ea9a077d3ffaa96a3c859f580f25890938e4f187c13a527
+DIST gallery-dl-1.22.3.gh.tar.gz 464060 BLAKE2B 6e9543675bb8118a73f81d1dffdfb20e91b385799a1bd9bbf2b5df331a384e55c4a503d5ac9e2f96e6d9d0f34913a4dcbb078c2b0044f9a418e8504e3b835cf9 SHA512 d544218f05a5ffb7eae83aa42bbc916d1b44233a50d11eed7d463c23718edaa144326dd8a88ca317f7fe0e8e1c737d5afc52e4db6d264be1cd3b63dbbfd76755
diff --git a/net-misc/gallery-dl/gallery-dl-1.22.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.22.3.ebuild
new file mode 100644
index 000000000000..60c3846252ce
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.22.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,ssl,xml"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}