summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-02 12:43:32 +0400
committerSam James <sam@gentoo.org>2024-05-09 01:20:00 +0100
commitd2d791f87eed8fed2f3acf505b4daeae047170a9 (patch)
tree4c0fb6ac25069c5b89049eaa21190e29d720e1cb /net-misc
parentx11-plugins/gkrellsun: Make errors fatal, fix build (diff)
downloadgentoo-d2d791f87eed8fed2f3acf505b4daeae047170a9.tar.gz
gentoo-d2d791f87eed8fed2f3acf505b4daeae047170a9.tar.bz2
gentoo-d2d791f87eed8fed2f3acf505b4daeae047170a9.zip
net-misc/vmnet: replace missing function with posix one, for musl
I'd rather drop this package, instead. [sam: Revbump.] Closes: https://bugs.gentoo.org/897956 Closes: https://bugs.gentoo.org/907888 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36055 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vmnet/files/vmnet-0.4-replace-missing-musl-function.patch20
-rw-r--r--net-misc/vmnet/vmnet-0.4-r2.ebuild (renamed from net-misc/vmnet/vmnet-0.4-r1.ebuild)3
2 files changed, 22 insertions, 1 deletions
diff --git a/net-misc/vmnet/files/vmnet-0.4-replace-missing-musl-function.patch b/net-misc/vmnet/files/vmnet-0.4-replace-missing-musl-function.patch
new file mode 100644
index 000000000000..5c4fbb152e9e
--- /dev/null
+++ b/net-misc/vmnet/files/vmnet-0.4-replace-missing-musl-function.patch
@@ -0,0 +1,20 @@
+diff -ru vmnet-0.4.orig/vmnet.c vmnet-0.4/vmnet.c
+--- vmnet-0.4.orig/vmnet.c 2024-04-02 08:35:41.521216356 +0000
++++ vmnet-0.4/vmnet.c 2024-04-02 08:37:34.760604906 +0000
+@@ -50,6 +50,7 @@
+ */
+
+ #define _GNU_SOURCE
++#define _XOPEN_SOURCE 700
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <pwd.h>
+@@ -197,7 +198,7 @@
+ int master, slave;
+ char name[1024];
+
+- master = getpt();
++ master = posix_openpt(O_RDWR);
+ if (master < 0) {
+ return 0;
+ }
diff --git a/net-misc/vmnet/vmnet-0.4-r1.ebuild b/net-misc/vmnet/vmnet-0.4-r2.ebuild
index 1fadcfdf151c..9f2519617783 100644
--- a/net-misc/vmnet/vmnet-0.4-r1.ebuild
+++ b/net-misc/vmnet/vmnet-0.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${WORKDIR}"/${P/-/_}-1.diff
"${FILESDIR}"/${PN}-0.4-Fix-build-with-Clang-16.patch
+ "${FILESDIR}"/${PN}-0.4-replace-missing-musl-function.patch
)
src_compile() {