summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-12-13 07:05:51 -0500
committerAnthony G. Basile <blueness@gentoo.org>2021-12-13 07:05:51 -0500
commitf37a7a6d03f9f5e75fd435132cea0a3a58669784 (patch)
treecd86db7821b3bc672455525a4989bb5414536f0a /net-misc
parentdev-util/rinstall: new package; add version 0.1.1 (diff)
downloadgentoo-f37a7a6d03f9f5e75fd435132cea0a3a58669784.tar.gz
gentoo-f37a7a6d03f9f5e75fd435132cea0a3a58669784.tar.bz2
gentoo-f37a7a6d03f9f5e75fd435132cea0a3a58669784.zip
net-misc/curl: remove deprecated configure options
Closes: https://bugs.gentoo.org/828553 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/curl-7.80.0.ebuild20
1 files changed, 3 insertions, 17 deletions
diff --git a/net-misc/curl/curl-7.80.0.ebuild b/net-misc/curl/curl-7.80.0.ebuild
index 261d977f06d5..eb15e98757d7 100644
--- a/net-misc/curl/curl-7.80.0.ebuild
+++ b/net-misc/curl/curl-7.80.0.ebuild
@@ -12,15 +12,14 @@ SRC_URI="https://curl.haxx.se/download/${P}.tar.xz"
LICENSE="curl"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap ipv6 kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp samba +smtp ssh ssl sslv3 static-libs test telnet +tftp threads winssl zstd"
-IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl curl_ssl_winssl"
+IUSE="adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap ipv6 kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp samba +smtp ssh ssl sslv3 static-libs test telnet +tftp threads zstd"
+IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl"
IUSE+=" nghttp3 quiche"
IUSE+=" elibc_Winnt"
# c-ares must be disabled for threads
# only one default ssl provider can be enabled
REQUIRED_USE="
- winssl? ( elibc_Winnt )
threads? ( !adns )
ssl? (
^^ (
@@ -28,7 +27,6 @@ REQUIRED_USE="
curl_ssl_mbedtls
curl_ssl_nss
curl_ssl_openssl
- curl_ssl_winssl
)
)"
@@ -76,9 +74,6 @@ RDEPEND="ldap? ( net-nds/openldap[${MULTILIB_USEDEP}] )
# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,ssl] )
# )
-# ssl providers to be added:
-# fbopenssl $(use_with spnego)
-
DEPEND="${RDEPEND}"
BDEPEND="dev-lang/perl
virtual/pkgconfig
@@ -114,7 +109,7 @@ multilib_src_configure() {
# TODO: in the future, we may want to add wolfssl (https://www.wolfssl.com/)
local myconf=()
- myconf+=( --without-gnutls --without-mbedtls --without-nss --without-polarssl --without-ssl --without-winssl )
+ myconf+=( --without-gnutls --without-mbedtls --without-nss --without-ssl )
myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
#myconf+=( --without-default-ssl-backend )
if use ssl ; then
@@ -134,10 +129,6 @@ multilib_src_configure() {
einfo "SSL provided by openssl"
myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
fi
- if use winssl || use curl_ssl_winssl; then
- einfo "SSL provided by Windows"
- myconf+=( --with-winssl )
- fi
if use curl_ssl_gnutls; then
einfo "Default SSL provided by gnutls"
@@ -151,9 +142,6 @@ multilib_src_configure() {
elif use curl_ssl_openssl; then
einfo "Default SSL provided by openssl"
myconf+=( --with-default-ssl-backend=openssl )
- elif use curl_ssl_winssl; then
- einfo "Default SSL provided by Windows"
- myconf+=( --with-default-ssl-backend=winssl )
else
eerror "We can't be here because of REQUIRED_USE."
fi
@@ -218,7 +206,6 @@ multilib_src_configure() {
--without-amissl
--without-bearssl
$(use_with brotli)
- --without-cyassl
--without-fish-functions-dir
$(use_with http2 nghttp2)
--without-hyper
@@ -233,7 +220,6 @@ multilib_src_configure() {
--without-rustls
--without-schannel
--without-secure-transport
- --without-spnego
--without-winidn
--without-wolfssl
--with-zlib