summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-01-20 06:59:53 +0100
committerJeroen Roovers <jer@gentoo.org>2016-01-20 07:06:04 +0100
commitf58d6fd424b527ee757e5aa69b1eb5588d007058 (patch)
tree2f24007cebc6a9b787f31c409338525f17569b05 /net-misc
parentdev-ruby/serialport: add ruby23 (diff)
downloadgentoo-f58d6fd424b527ee757e5aa69b1eb5588d007058.tar.gz
gentoo-f58d6fd424b527ee757e5aa69b1eb5588d007058.tar.bz2
gentoo-f58d6fd424b527ee757e5aa69b1eb5588d007058.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.01.15.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index b892e026e675..9df211501fe3 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -4,3 +4,4 @@ DIST youtube-dl-2015.12.29.tar.gz 1863530 SHA256 4ff67c9cb65f36f0409dc2f35953fe1
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.01.09.tar.gz 1888095 SHA256 463cfed59a1e2c6609a8e3d3354e0494833f1b249fe1979984b06a51ac5c904d SHA512 bc022939ec2cdd574ca5ecedbfb349d516881996b50aac6a96220d94c358a38ff4ec8f8bd50195e2a6087dee558149e820935c60eaff8bb521bc8828413d44bf WHIRLPOOL a9fcffa926a72d6558b583390f1023568ee8c97695a87e15add7d72b7bd556c23056948df2bfb55902d7f2cbc3206c69844bee8b5e8ea1e3d7786b58806108f6
DIST youtube-dl-2016.01.14.tar.gz 1891877 SHA256 8fb4829219c591d0b9a94ebc7bda933db33d4b04d9875a8d725affdbc28e5aad SHA512 2c75fb70472daa7ee83c3a5c25af3c0a9a8928cc5c0517f4b566164495aece3274af5003f21fd861f543b32659ea507c8bf96319c6451a9ba9f16320433f4b5d WHIRLPOOL 74bb7949baff66a87729ec60b9c33451581325bd1e412d8d48bf7fa3fa095873849a3efe5c36ccc15e92a89ebfbe2ae50ddf140f900372bca87abe53213f60c3
+DIST youtube-dl-2016.01.15.tar.gz 1898595 SHA256 c1e22ca3286aff74a668d1f8ef5c84c37bee2c269824e71ffdb23356a8735c44 SHA512 37cfb097e3345f9775a867d54f61eb60a94ba3408c3ef448ebb895e8bb74915f30f4ae87030d7f5d48bd9dfa2bccff302a6ede28624b7d17c4f164a9561d47db WHIRLPOOL 8a8653e49a043a34934b0e8c68be21a79899be4b391b0c7e6fceb6583f0ec22204349ca4aad0ef56703bb24ce8e4362d1c1cec95bef89cc24743191c6af3c1e8
diff --git a/net-misc/youtube-dl/youtube-dl-2016.01.15.ebuild b/net-misc/youtube-dl/youtube-dl-2016.01.15.ebuild
new file mode 100644
index 000000000000..5db7401e49ee
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.01.15.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink chaturbate drtuber eporner eroprofile
+ extremetube fourtube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies mofosex motherless porn91 pornhd pornotube
+ pornovoisines pornoxo redtube sexykarma sexu sunporno slutload
+ spankbang spankwire thisav trutube tube8 vporn xbef xnxx xtube
+ xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}