summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-05-04 22:44:47 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-05-04 22:46:11 +0200
commitf7616a54786c4e6034eee288d9b57c5c434d5410 (patch)
tree48ccb8efbc6e307c8a7a623049b24db801ca25bb /net-misc
parentwww-plugins/chrome-binary-plugins: automated update (92.0.4496.0) (diff)
downloadgentoo-f7616a54786c4e6034eee288d9b57c5c434d5410.tar.gz
gentoo-f7616a54786c4e6034eee288d9b57c5c434d5410.tar.bz2
gentoo-f7616a54786c4e6034eee288d9b57c5c434d5410.zip
net-misc/realtek-r8152: 2.15.0 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/realtek-r8152/Manifest1
-rw-r--r--net-misc/realtek-r8152/realtek-r8152-2.15.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/realtek-r8152/Manifest b/net-misc/realtek-r8152/Manifest
index b29e20ede111..6827d73dcf86 100644
--- a/net-misc/realtek-r8152/Manifest
+++ b/net-misc/realtek-r8152/Manifest
@@ -1 +1,2 @@
DIST realtek-r8152-2.14.0.tar.gz 88356 BLAKE2B c530080cab5e6f7433aa6452e3c5f1f19f14c2ac473751958d85efa5553d2b2889d80cc47c2ad4064ad5673008df97dce197254f445c5fc7ae3905c7833e1641 SHA512 2908e9963b6bec9d638514e6a54ab8bca0b56c4866245f476889e4c8462c36f2bece86abac2e5ece9aee1776f00f7d4a67fd5561d830a67e02e386d79aba07dd
+DIST realtek-r8152-2.15.0.tar.gz 93420 BLAKE2B 24b7a71adfddde3ff2ecc8c0b92d51f50202dada31a2f86a19d518f37814dd52d7ca5ffb5f81f07c7a92436f4fef53c8538a64d6bc5afbb0b6b7ccbace0a7923 SHA512 b46012d6e9c48ebb0eb0b7387933977bc56df7a9e010f0707907719e833a8f409d5af55ef84ebb0d54de89239e69697b6995c75e194ef7d0fa2c371d5fc362ba
diff --git a/net-misc/realtek-r8152/realtek-r8152-2.15.0.ebuild b/net-misc/realtek-r8152/realtek-r8152-2.15.0.ebuild
new file mode 100644
index 000000000000..ac2d53b76ca1
--- /dev/null
+++ b/net-misc/realtek-r8152/realtek-r8152-2.15.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod linux-info udev
+
+SRC_URI="https://github.com/slashbeast/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Out-of-tree driver for Realtek's 2.5 GbE USB NICs."
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-usb-3-0-software"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="
+ virtual/linux-sources
+ sys-kernel/linux-headers
+"
+RDEPEND=""
+
+MODULE_NAMES="r8152(net/usb)"
+
+pkg_setup() {
+ linux_config_exists
+
+ for module in USB_USBNET USB_NET_CDC_NCM USB_NET_CDCETHER; do
+ linux_chkconfig_module "${module}" || ewarn "CONFIG_${module} needs to be built as module (builtin doesn't work)"
+ done
+
+ linux_chkconfig_present MII || ewarn "CONFIG_MII needs to be built as module or builtin into the kernel"
+
+ linux_chkconfig_present USB_RTL8152 && ewarn "CONFIG_USB_RTL8152 must NOT be enabled in the kernel!"
+
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="modules"
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERNELDIR=${KERNEL_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ udev_newrules 50-usb-realtek-net.rules 50-usb-realtek-net.rules
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+
+ echo
+ elog "If the cdc_ncm was loaded before this r8152 driver, one might get a flood"
+ elog "of 'usbN: network connection: disconnected' in kernel log."
+ elog "In that case one needs to unload r8152, cdc_ether and cdc_ncm modules and"
+ elog "let udev load them in right order or manually load r8152."
+ echo
+}