summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-02-21 20:57:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-22 21:50:55 +0100
commitfadcab79ce2a55794c009b4c3fb5c4c53dac6985 (patch)
tree47a4eb31c210623f6b1e3f874d1179500819bc1b /net-misc
parentdev-libs/hyperscan: Version bump 5.1.0 (diff)
downloadgentoo-fadcab79ce2a55794c009b4c3fb5c4c53dac6985.tar.gz
gentoo-fadcab79ce2a55794c009b4c3fb5c4c53dac6985.tar.bz2
gentoo-fadcab79ce2a55794c009b4c3fb5c4c53dac6985.zip
net-misc/ncp: EAPI7 bump, use HTTPS
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11126 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ncp/ncp-1.2.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/ncp/ncp-1.2.4-r1.ebuild b/net-misc/ncp/ncp-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..6309febf0296
--- /dev/null
+++ b/net-misc/ncp/ncp-1.2.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for copying files in a LAN (npoll, npush)"
+HOMEPAGE="https://www.fefe.de/ncp/"
+SRC_URI="https://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="public-domain" # mail from author, bug 446540
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="diet"
+
+DEPEND=">=dev-libs/libowfat-0.28-r1
+ diet? ( dev-libs/dietlibc )"
+
+src_prepare() {
+ default
+ rm Makefile || die
+ sed -e '/^ncp:/,+5s:strip:#strip:' \
+ -i GNUmakefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(use diet && echo "diet -Os ")$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP="#"
+}
+
+src_install() {
+ dobin ${PN}
+ dosym ${PN} /usr/bin/npoll
+ dosym ${PN} /usr/bin/npush
+
+ doman ncp.1 npush.1
+ dodoc NEWS
+}