summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2018-12-07 17:27:20 -0800
committerPatrick McLean <chutzpah@gentoo.org>2018-12-07 17:27:20 -0800
commitfe272e74d62b707e8083fecac8ca667760d0dc16 (patch)
treedfed4bf87db7d29a6b06250d8025990f720b5cb7 /net-misc
parentdev-python/netifaces: add Python 3.7 support (diff)
downloadgentoo-fe272e74d62b707e8083fecac8ca667760d0dc16.tar.gz
gentoo-fe272e74d62b707e8083fecac8ca667760d0dc16.tar.bz2
gentoo-fe272e74d62b707e8083fecac8ca667760d0dc16.zip
net-misc/openssh: Fix X509+libressl-2.8 and remove /run in 7.9_p1
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/files/openssh-7.9_p1-X509-dont-make-piddir.patch16
-rw-r--r--net-misc/openssh/files/openssh-7.9_p1-libressl-2.8.patch16
-rw-r--r--net-misc/openssh/openssh-7.9_p1.ebuild3
3 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/openssh/files/openssh-7.9_p1-X509-dont-make-piddir.patch b/net-misc/openssh/files/openssh-7.9_p1-X509-dont-make-piddir.patch
new file mode 100644
index 000000000000..c30ca2785448
--- /dev/null
+++ b/net-misc/openssh/files/openssh-7.9_p1-X509-dont-make-piddir.patch
@@ -0,0 +1,16 @@
+--- a/openssh-7.9p1+x509-11.5.diff 2018-12-07 17:24:03.211328918 -0800
++++ b/openssh-7.9p1+x509-11.5.diff 2018-12-07 17:24:13.399262277 -0800
+@@ -40681,12 +40681,11 @@
+
+ install: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files install-sysconf host-key check-config
+ install-nokeys: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files install-sysconf
+-@@ -333,6 +351,8 @@
++@@ -333,6 +351,7 @@
+ $(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)5
+ $(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)8
+ $(MKDIR_P) $(DESTDIR)$(libexecdir)
+ + $(MKDIR_P) $(DESTDIR)$(sshcadir)
+-+ $(MKDIR_P) $(DESTDIR)$(piddir)
+ $(MKDIR_P) -m 0755 $(DESTDIR)$(PRIVSEP_PATH)
+ $(INSTALL) -m 0755 $(STRIP_OPT) ssh$(EXEEXT) $(DESTDIR)$(bindir)/ssh$(EXEEXT)
+ $(INSTALL) -m 0755 $(STRIP_OPT) scp$(EXEEXT) $(DESTDIR)$(bindir)/scp$(EXEEXT)
diff --git a/net-misc/openssh/files/openssh-7.9_p1-libressl-2.8.patch b/net-misc/openssh/files/openssh-7.9_p1-libressl-2.8.patch
new file mode 100644
index 000000000000..58f3ce2922ec
--- /dev/null
+++ b/net-misc/openssh/files/openssh-7.9_p1-libressl-2.8.patch
@@ -0,0 +1,16 @@
+--- openssh-7.9p1.orig/evp-compat.h 2018-12-07 17:07:37.929762570 -0800
++++ openssh-7.9p1/evp-compat.h 2018-12-07 17:08:03.923592845 -0800
+@@ -100,11 +100,13 @@
+ }
+
+
++#if LIBRESSL_VERSION_NUMBER < 0x20800000L
+ static inline int
+ EVP_CIPHER_CTX_encrypting(const EVP_CIPHER_CTX *ctx)
+ {
+ return(ctx->encrypt);
+ }
++#endif /* LIBRESSL_VERSION_NUMBER < 0x20800000L */
+
+
+ static inline void*
diff --git a/net-misc/openssh/openssh-7.9_p1.ebuild b/net-misc/openssh/openssh-7.9_p1.ebuild
index 83ff7a4d299d..a8cacd6542e6 100644
--- a/net-misc/openssh/openssh-7.9_p1.ebuild
+++ b/net-misc/openssh/openssh-7.9_p1.ebuild
@@ -124,9 +124,11 @@ src_prepare() {
if use X509 ; then
pushd "${WORKDIR}" || die
eapply "${FILESDIR}/${P}-X509-glue.patch"
+ eapply "${FILESDIR}/${P}-X509-dont-make-piddir.patch"
popd || die
eapply "${WORKDIR}"/${X509_PATCH%.*}
+ eapply "${FILESDIR}"/${PN}-7.9_p1-libressl-2.8.patch
# We need to patch package version or any X.509 sshd will reject our ssh client
# with "userauth_pubkey: could not parse key: string is too large [preauth]"
@@ -389,6 +391,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/sshd.{service,socket}
systemd_newunit "${FILESDIR}"/sshd_at.service 'sshd@.service'
+ ls -la "${D}"/run
}
pkg_preinst() {