summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-01-01 11:20:57 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-01-02 11:44:10 -0800
commit072752b8b9ba5162deb4f0c6ec9487ac7c1f1708 (patch)
treee82e5dc4ca9c63752f407377d42a718d6320410c /net-nds/nsscache/nsscache-0.30.ebuild
parentdev-perl/DBD-Pg: Specify postgresql slot (any) (diff)
downloadgentoo-072752b8b9ba5162deb4f0c6ec9487ac7c1f1708.tar.gz
gentoo-072752b8b9ba5162deb4f0c6ec9487ac7c1f1708.tar.bz2
gentoo-072752b8b9ba5162deb4f0c6ec9487ac7c1f1708.zip
net-nds/nsscache: bump.
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-nds/nsscache/nsscache-0.30.ebuild')
-rw-r--r--net-nds/nsscache/nsscache-0.30.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-nds/nsscache/nsscache-0.30.ebuild b/net-nds/nsscache/nsscache-0.30.ebuild
new file mode 100644
index 000000000000..18a0d1c792e7
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.30.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="https://github.com/google/nsscache"
+SRC_URI="https://github.com/google/nsscache/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="nssdb nsscache"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/python-ldap[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ nssdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+RESTRICT="test"
+S="${WORKDIR}/${PN}-version-${PV}"
+
+src_prepare() {
+ find "${S}" -name '*.py' -exec \
+ sed -i '/^import bsddb$/s,bsddb,bsddb3 as bsddb,g' \
+ {} \+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+
+ keepdir /var/lib/nsscache
+}