summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-11-25 08:47:25 -0500
committerBrian Evans <grknight@gentoo.org>2015-11-25 08:47:25 -0500
commita14654168015ffc03c59a82acc7f81b2ea264266 (patch)
treeba4b80f0b8db5e6bf8d26e763f36574eabbb6178 /net-nds/phpldapadmin
parentprofiles/package.mask: Fix eselect-python mask to use >= when possible (diff)
downloadgentoo-a14654168015ffc03c59a82acc7f81b2ea264266.tar.gz
gentoo-a14654168015ffc03c59a82acc7f81b2ea264266.tar.bz2
gentoo-a14654168015ffc03c59a82acc7f81b2ea264266.zip
net-nds/phpldapadmin: Remove depend.php from inherit wrt bug 552854
This simply replaces the function call with the dep it was adding. No effective dep changes. Ack by jmbsvicetto on IRC Package-Manager: portage-2.2.25
Diffstat (limited to 'net-nds/phpldapadmin')
-rw-r--r--net-nds/phpldapadmin/phpldapadmin-1.2.3-r1.ebuild8
-rw-r--r--net-nds/phpldapadmin/phpldapadmin-1.2.3.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/net-nds/phpldapadmin/phpldapadmin-1.2.3-r1.ebuild b/net-nds/phpldapadmin/phpldapadmin-1.2.3-r1.ebuild
index 6ce53f6e34f0..84052a101bf4 100644
--- a/net-nds/phpldapadmin/phpldapadmin-1.2.3-r1.ebuild
+++ b/net-nds/phpldapadmin/phpldapadmin-1.2.3-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit webapp depend.php
+inherit webapp
DESCRIPTION="phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server"
HOMEPAGE="http://phpldapadmin.sourceforge.net"
@@ -15,10 +15,10 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE=""
RDEPEND="dev-lang/php[hash,ldap,session,xml,nls]
- || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ virtual/httpd-php"
need_httpd_cgi
-need_php_httpd
src_prepare() {
mv config/config.php.example config/config.php
diff --git a/net-nds/phpldapadmin/phpldapadmin-1.2.3.ebuild b/net-nds/phpldapadmin/phpldapadmin-1.2.3.ebuild
index 15be856e0de1..009513114bf5 100644
--- a/net-nds/phpldapadmin/phpldapadmin-1.2.3.ebuild
+++ b/net-nds/phpldapadmin/phpldapadmin-1.2.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit webapp depend.php
+inherit webapp
DESCRIPTION="phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server"
HOMEPAGE="http://phpldapadmin.sourceforge.net"
@@ -15,10 +15,10 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE=""
RDEPEND="dev-lang/php[hash,ldap,session,xml,nls]
- || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ virtual/httpd-php"
need_httpd_cgi
-need_php_httpd
src_prepare() {
mv config/config.php.example config/config.php