summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:38:50 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:38:50 +0100
commitd2e44fa7b4e732f46ffc00896550f1ffa30ccd03 (patch)
tree592c6b3e2e4e8549975d36c6db9d57a07d504dea /net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild
parentnet-nds/yp-tools: add misisng libcrypt dependency (diff)
downloadgentoo-d2e44fa7b4e732f46ffc00896550f1ffa30ccd03.tar.gz
gentoo-d2e44fa7b4e732f46ffc00896550f1ffa30ccd03.tar.bz2
gentoo-d2e44fa7b4e732f46ffc00896550f1ffa30ccd03.zip
net-nds/tac_plus: add missing libcrypt dependency
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild')
-rw-r--r--net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild b/net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild
deleted file mode 100644
index 6f9e32eef0dd..000000000000
--- a/net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-MY_P="tacacs+-F${PV}"
-DESCRIPTION="An updated version of Cisco's TACACS+ server"
-HOMEPAGE="http://www.shrubbery.net/tac_plus/"
-SRC_URI="ftp://ftp.shrubbery.net/pub/tac_plus/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="HPND RSA GPL-2" # GPL-2 only for init script
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug finger maxsess tcpd skey static-libs"
-
-DEPEND="
- net-libs/libnsl
- sys-libs/pam
- skey? ( >=sys-auth/skey-1.1.5-r1 )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-parallelmake.patch
- "${FILESDIR}"/${P}-deansification.patch
-)
-
-src_prepare() {
- default
-
- AT_M4DIR="." eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with skey) \
- $(use_with tcpd libwrap) \
- $(use_enable debug) \
- $(use_enable finger) \
- $(use_enable maxsess) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use static-libs ; then
- find "${D}" -name '*.la' -delete || die "Unable to remove spurious libtool archive"
- fi
-
- dodoc CHANGES FAQ
-
- newinitd "${FILESDIR}/tac_plus.init2" tac_plus
- newconfd "${FILESDIR}/tac_plus.confd2" tac_plus
-
- insinto /etc/tac_plus
- newins "${FILESDIR}/tac_plus.conf2" tac_plus.conf
-}