summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-08-02 01:35:02 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-08-13 15:23:10 +0200
commite30c8eff08858e2873016e615d0a2925db7b54e2 (patch)
tree8126986b2bff753e39a532a32651c80c8956aafb /net-news/rssguard/rssguard-3.4.1.ebuild
parentdev-python/sphinx: keyworded 1.5.2 for ppc, bug #605278 (diff)
downloadgentoo-e30c8eff08858e2873016e615d0a2925db7b54e2.tar.gz
gentoo-e30c8eff08858e2873016e615d0a2925db7b54e2.tar.bz2
gentoo-e30c8eff08858e2873016e615d0a2925db7b54e2.zip
net-news/rssguard: version bump to 3.4.1.
Closes: https://github.com/gentoo/gentoo/pull/5271
Diffstat (limited to 'net-news/rssguard/rssguard-3.4.1.ebuild')
-rw-r--r--net-news/rssguard/rssguard-3.4.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-news/rssguard/rssguard-3.4.1.ebuild b/net-news/rssguard/rssguard-3.4.1.ebuild
new file mode 100644
index 000000000000..8f2495596002
--- /dev/null
+++ b/net-news/rssguard/rssguard-3.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="A tiny RSS and Atom feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard"
+SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug webengine"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.6:5
+ >=dev-qt/qtgui-5.6:5
+ >=dev-qt/qtnetwork-5.6:5
+ >=dev-qt/qtsql-5.6:5
+ >=dev-qt/qtwidgets-5.6:5
+ >=dev-qt/qtxml-5.6:5
+ webengine? ( >=dev-qt/qtwebengine-5.6:5[widgets] )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/linguist-tools-5.6:5
+"
+
+src_prepare() {
+ default
+
+ # remove bundled qtbase translations
+ rm -v localization/qtbase* || die
+ sed -i -e "s|localization/qtbase_[a-z][a-z].ts||g" ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ USE_WEBENGINE=$(usex webengine true false) \
+ LRELEASE_EXECUTABLE="$(qt5_get_bindir)/lrelease" \
+ PREFIX="${EPREFIX}"/usr \
+ INSTALL_ROOT=.
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}