summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-news/rsstool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-news/rsstool')
-rw-r--r--net-news/rsstool/Manifest1
-rw-r--r--net-news/rsstool/metadata.xml8
-rw-r--r--net-news/rsstool/rsstool-1.0.1_rc2.ebuild39
3 files changed, 48 insertions, 0 deletions
diff --git a/net-news/rsstool/Manifest b/net-news/rsstool/Manifest
new file mode 100644
index 000000000000..b9798c70e16f
--- /dev/null
+++ b/net-news/rsstool/Manifest
@@ -0,0 +1 @@
+DIST rsstool-1.0.1rc2-src.zip 135622 SHA256 6eba02cc8d2a3efeca137cfbaec674ef4d75c82d5998442d5b99ed67a704664e SHA512 9c04f194e1940909409f6039bd8842e1ff558ec2849e42949143b4cddf7472f7e65925d2acaae40bb423ce26b7c6e66fa675208c3f61ea7e010040b6b8d8af0d WHIRLPOOL 4f1de751854645b7070aa08e59617c421b92e371be14d98268af2b6365b4c3c33ec786fadf8ba6c5cae245cf074349175ef8c1225c8aa35f5bdca10f74a962ef
diff --git a/net-news/rsstool/metadata.xml b/net-news/rsstool/metadata.xml
new file mode 100644
index 000000000000..4494d9a01242
--- /dev/null
+++ b/net-news/rsstool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-news</herd>
+ <upstream>
+ <remote-id type="sourceforge">rsstool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-news/rsstool/rsstool-1.0.1_rc2.ebuild b/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
new file mode 100644
index 000000000000..971529ec81cd
--- /dev/null
+++ b/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MY_P=${PN}-${PV/_}
+
+DESCRIPTION="cmdline tool to read, parse, merge, and write RSS (and Atom) feeds"
+HOMEPAGE="http://rsstool.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}-src/src
+
+src_prepare() {
+ sed -e '1i#!/bin/bash' -i configure || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR="/usr/bin" install
+
+ dohtml ../{changes,faq,readme}.html
+}