summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2022-08-23 03:23:10 -0400
committerSam James <sam@gentoo.org>2022-10-12 21:44:18 +0100
commit3d401b78c411c427688f239ec99734137a86327d (patch)
tree871bea5758d41242f520b322acf05ed2882e5e2e /net-nntp/sabnzbd
parentmedia-video/makemkv: Bump to 1.17.2, drop old 1.17.1 (diff)
downloadgentoo-3d401b78c411c427688f239ec99734137a86327d.tar.gz
gentoo-3d401b78c411c427688f239ec99734137a86327d.tar.bz2
gentoo-3d401b78c411c427688f239ec99734137a86327d.zip
net-nntp/sabnzbd: version bump to 3.6.1
Signed-off-by: Joe Kappus <joe@wt.gd> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp/sabnzbd')
-rw-r--r--net-nntp/sabnzbd/Manifest1
-rw-r--r--net-nntp/sabnzbd/sabnzbd-3.6.1.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index 53af772a1ea6..d955c1f8e017 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -2,3 +2,4 @@ DIST SABnzbd-3.3.1-src.tar.gz 2786705 BLAKE2B 1ce58c2fd51304395402e2ad4379556e9f
DIST SABnzbd-3.4.1-src.tar.gz 2978066 BLAKE2B d7fc9df71ccf0ee8d9282fb7ec7a088e5f9d4cf99f07d120a1e89ae18f1f3c5e34bd4717bdb79dd097f219021e10c56150b95faf6a43bc896060c1249f63dcaf SHA512 befc5d26860702d0a0b945e0fde35244869e2a766ae6819aafd642bad0897ff439830b5c72f914c139c3f8bfad7fccd9bced9bced8db6349a341f9c3be302fe8
DIST SABnzbd-3.4.2-src.tar.gz 2979084 BLAKE2B 2e75212226221c283e46533c46dd6eb3f880d636d73d8e3620650068d9ad67f3f1f55a9a418cdc74876f7e12a37c94a3dbcd79112f46fd322301d93bfbdf9063 SHA512 d34a59540c9bb371de912dd0501b3e6dfa392da4d833cfcaf3b550bd11342439a2b64b2205207cd0d0a9c3947cdd1b43ca90d41b130d21e28cede5bf362fd5ae
DIST SABnzbd-3.6.0-src.tar.gz 5052873 BLAKE2B 41b6fb818e9bcf40bedd16e9b2a0d5b2590cdbef8a29187f0e995d11d036c60364ed6f297eb6c2bb3f257040ef66b9bd26bc8464b9af2adfac3922f4817918a6 SHA512 277953a10211b72532ef4c490cc77516ad4691e15f55bbc08572edba8fc4154ddde5d6bd62ea79c2279dad571038cab25194d6764bf1377dda25d522a5838a92
+DIST SABnzbd-3.6.1-src.tar.gz 5051796 BLAKE2B a123b148290dd135f2eb375ce712b19b241907fd78935d9ec8cbb1b80b695c0aa0f92aff6b533e1966c84b9024f4c154a9708496331f85111906e6b068c22410 SHA512 7864f9252bbe8d66cd307e78911b03973554f1a2ccbba0e5ede536e4b7c679fe48cc1e334209688a9f9cd289b8bafc9a317dd02c6563e4151eba4fe2d81b9ddc
diff --git a/net-nntp/sabnzbd/sabnzbd-3.6.1.ebuild b/net-nntp/sabnzbd/sabnzbd-3.6.1.ebuild
new file mode 100644
index 000000000000..6f28bd82c53c
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-3.6.1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit optfeature python-single-r1 systemd
+
+MY_PV="${PV/_rc/RC}"
+MY_PV="${MY_PV//_pre*}"
+
+MY_P="${PN/sab/SAB}-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cheetah3[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.10[${PYTHON_USEDEP}]
+ >=dev-python/guessit-3.1.0[${PYTHON_USEDEP}]
+ dev-python/notify2[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/puremagic[${PYTHON_USEDEP}]
+ >=dev-python/sabyenc-5.4.2[${PYTHON_USEDEP}]
+ ')
+"
+
+RDEPEND="
+ ${DEPEND}
+ >=app-arch/par2cmdline-0.4
+ net-misc/wget
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ ')
+ www-apps/chromedriver-bin
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ local d
+
+ for d in email icons interfaces locale po sabnzbd scripts tools; do
+ insinto "/usr/share/${PN}/${d}"
+ doins -r ${d}/*
+ done
+
+ exeinto "/usr/share/${PN}"
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}/usr/share/${PN}"
+ python_optimize "${ED}/usr/share/${PN}"
+
+ newinitd "${FILESDIR}/${PN}-r1.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ diropts -o "${PN}" -g "${PN}"
+ dodir "/etc/${PN}"
+ keepdir "/var/log/${PN}"
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc ISSUES.txt README.mkd
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+src_test() {
+ EPYTEST_IGNORE=(
+ # Requires dev-python/tavern which is not currently packaged for Gentoo
+ tests/test_functional_api.py
+ )
+ epytest
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: /var/lib/${PN}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ fi
+
+ optfeature "7z archive support" app-arch/p7zip
+ optfeature "rar archive support" app-arch/unrar app-arch/rar
+ optfeature "zip archive support" app-arch/unzip
+}