summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-01-30 16:15:04 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-01-30 16:15:26 +0100
commit30aad951282e981b515b1463ba441287e815d174 (patch)
tree69a210c30a79724ba44b1031c73b867acc34f8b4 /net-nntp/tin/tin-2.4.2.ebuild
parentnet-misc/rabbitmq-server: version bump (diff)
downloadgentoo-30aad951282e981b515b1463ba441287e815d174.tar.gz
gentoo-30aad951282e981b515b1463ba441287e815d174.tar.bz2
gentoo-30aad951282e981b515b1463ba441287e815d174.zip
net-nntp/tin: Bumps version to 2.4.2.
Cleans net-misc/urlview dependency (bug #646118) Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-nntp/tin/tin-2.4.2.ebuild')
-rw-r--r--net-nntp/tin/tin-2.4.2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/net-nntp/tin/tin-2.4.2.ebuild b/net-nntp/tin/tin-2.4.2.ebuild
new file mode 100644
index 000000000000..1846e91b8354
--- /dev/null
+++ b/net-nntp/tin/tin-2.4.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses:0[unicode?]
+ unicode? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable etiquette) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen}
+}
+
+#src_compile() {
+# emake build
+#}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}