summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-18 18:32:08 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-18 18:36:53 +0200
commit7a1f2a15f471f9f784ee2d4600ea2b832a9812bf (patch)
treec6fcd859c6778d6d819528b5258b8a65c57eb016 /net-nntp
parentsys-apps/portage: 3.0.20-r4 regression fix revbump (diff)
downloadgentoo-7a1f2a15f471f9f784ee2d4600ea2b832a9812bf.tar.gz
gentoo-7a1f2a15f471f9f784ee2d4600ea2b832a9812bf.tar.bz2
gentoo-7a1f2a15f471f9f784ee2d4600ea2b832a9812bf.zip
net-nntp/sabnzbd: bump to v3.3.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/sabnzbd/Manifest1
-rw-r--r--net-nntp/sabnzbd/sabnzbd-3.3.1.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index 0f91d6898d41..5cb7e6b14ab0 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -1,2 +1,3 @@
DIST SABnzbd-3.2.1-src.tar.gz 2777984 BLAKE2B 6e0ebe122a01f8cbd5b26eefe3728478dd348b3d11fb274c2a146b7567f306074ddd93b438463471e22fc77c6c2223e864c6019ba0d7ab464162451e9f9c8cb9 SHA512 ace29199eb6f03450d25fc3b79960d1afc336f0013771bcf698e7df5c5e5ed920ad783f542ba8f3dbcd451d279993a6d4299d78075184e43ad74411ac19c3f59
DIST SABnzbd-3.3.0-src.tar.gz 2786354 BLAKE2B aa5034d99b570c6ae643209663b2b292d0dcc06dabcb09bb9b28e7b38248b88c98736ae35cff7c6e4c93d2d6a44b716dbf2fd8c7cf71f0b5a65ef0c625d9d00e SHA512 eefc20c9f6921a1efc8f7cafc6f544949dccacacfa01aff29a32355431f8d62d9f4f36312271987b10ff96e9b5f8c6bef390f594282ce42b743faa556489e7fa
+DIST SABnzbd-3.3.1-src.tar.gz 2786705 BLAKE2B 1ce58c2fd51304395402e2ad4379556e9f1a1471d524d1b3b969b9b201edf15dece1f12d9891695e9dbb02664014c2540ed9fce02b4418fc3100cd3bb2717983 SHA512 0ab7001935f19c8e1829051949965977b895456b83ee26b6379fd9c7024d114d5bdd0701d747c8935bb46a829d46379e4406012007a9039c43fb99e4db3ee920
diff --git a/net-nntp/sabnzbd/sabnzbd-3.3.1.ebuild b/net-nntp/sabnzbd/sabnzbd-3.3.1.ebuild
new file mode 100644
index 000000000000..e842f9ed1be0
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-3.3.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+# Require python-2 with sqlite USE flag
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 systemd
+
+MY_PV="${PV/_rc/RC}"
+MY_PV="${MY_PV//_pre*}"
+
+MY_P="${PN/sab/SAB}-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+7za +rar unzip"
+
+# Sabnzbd is installed to /usr/share/ as upstream makes it clear they should not
+# be in python's sitedir. See: https://sabnzbd.org/wiki/advanced/unix-packaging
+
+COMMON_DEPS="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/cheetah3[${PYTHON_MULTI_USEDEP}]
+ dev-python/cherrypy[${PYTHON_MULTI_USEDEP}]
+ dev-python/configobj[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/feedparser-6[${PYTHON_MULTI_USEDEP}]
+ dev-python/notify2[${PYTHON_MULTI_USEDEP}]
+ dev-python/portend[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/sabyenc-4[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+DEPEND="${COMMON_DEPS}"
+
+RDEPEND="
+ ${COMMON_DEPS}
+ >=app-arch/par2cmdline-0.4
+ net-misc/wget
+ 7za? ( app-arch/p7zip )
+ rar? ( || ( app-arch/unrar app-arch/rar ) )
+ unzip? ( >=app-arch/unzip-5.5.2 )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ MY_HOMEDIR="/var/lib/${PN}"
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ local d
+
+ for d in email icons interfaces locale po sabnzbd scripts tools; do
+ insinto "/usr/share/${PN}/${d}"
+ doins -r ${d}/*
+ done
+
+ exeinto "/usr/share/${PN}"
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}/usr/share/${PN}"
+ python_optimize "${ED}/usr/share/${PN}"
+
+ newinitd "${FILESDIR}/${PN}-r1.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ diropts -o "${PN}" -g "${PN}"
+ dodir "/etc/${PN}"
+ keepdir "/var/log/${PN}"
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc ISSUES.txt README.mkd
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: ${MY_HOMEDIR}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ else
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 3; then
+ ewarn
+ ewarn "Due to changes in this release, the queue will be converted when ${PN}"
+ ewarn "is started for the first time. Job order, settings and data will be"
+ ewarn "preserved, but all jobs will be unpaused and URLs that did not finish"
+ ewarn "fetching before the upgrade will be lost!"
+ ewarn
+ break
+ fi
+ done
+ fi
+}