summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2021-01-22 23:24:05 -0600
committerSam James <sam@gentoo.org>2021-01-24 01:48:02 +0000
commite0b9b10345bbd1d162bfb3d8a2430b60d3341666 (patch)
tree42e32a80f1cf6888d0320bd42271ad1f1af698ab /net-nntp
parentsys-libs/zlib: Stabilize 1.2.11-r3 sparc, #766606 (diff)
downloadgentoo-e0b9b10345bbd1d162bfb3d8a2430b60d3341666.tar.gz
gentoo-e0b9b10345bbd1d162bfb3d8a2430b60d3341666.tar.bz2
gentoo-e0b9b10345bbd1d162bfb3d8a2430b60d3341666.zip
net-nntp/tin: security bump to 2.4.5
Bump to EAPI 7, formatting fixes. Bug: https://bugs.gentoo.org/724510 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/19166 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/Manifest1
-rw-r--r--net-nntp/tin/tin-2.4.5.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
index 616ee6ecf8b9..068845f1028d 100644
--- a/net-nntp/tin/Manifest
+++ b/net-nntp/tin/Manifest
@@ -1 +1,2 @@
DIST tin-2.4.2.tar.xz 1491388 BLAKE2B 16fab433443d5859cc9661790ff837e8f45767e7f45bafc54a8cffc94fd52cb4ee7afb98e579db49c16148b0f521374404a0f26d75a07a24c1c7a1dc5e3a57fe SHA512 70a9957d5bf5af1bb182a3f4e62795cd5862b7282b7fc0c231c3bd02d83950cdbdd502d8a2cc5eae20b29af584e4f794f03378742b47ed93fc5c61ac5bbb01b6
+DIST tin-2.4.5.tar.xz 1559164 BLAKE2B 4efea88c7f76aef91a848c9ed5d82efac640360e41c515015d406e84ed5ce639bbcd17eff29939312ebf83adb8bb84bc7a4f04833cd7cc0781f92b377a0cb31f SHA512 4ec1c4990ce8d9a46204c0064f19c5c2b99848201c37562f8df76de5be84fdd2bcd35cbc3e9f20233f636522e086ac031a5a9cb65bd22a53eda619dcce86adbc
diff --git a/net-nntp/tin/tin-2.4.5.ebuild b/net-nntp/tin/tin-2.4.5.ebuild
new file mode 100644
index 000000000000..f79d83b2aae4
--- /dev/null
+++ b/net-nntp/tin/tin-2.4.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses:0[unicode?]
+ unicode? ( dev-libs/icu:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable etiquette) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen}
+}
+
+src_compile() {
+ # To build from the root dir you have to call `make build`, not just
+ # `make`.
+ emake build
+}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}