summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-07-23 01:21:34 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-07-23 18:37:24 -0400
commit3e838f50b626c6c775c29edfb55da3b3263ecccc (patch)
tree695bfd4beb8eb770edaa84bf1ea3757b3f44493b /net-p2p/airdcpp-webclient
parentdev-perl/Config-Crontab: Bump to version 1.410.0 (diff)
downloadgentoo-3e838f50b626c6c775c29edfb55da3b3263ecccc.tar.gz
gentoo-3e838f50b626c6c775c29edfb55da3b3263ecccc.tar.bz2
gentoo-3e838f50b626c6c775c29edfb55da3b3263ecccc.zip
net-p2p/airdcpp-webclient: bump to 1.0.7
Require openssl to be built with USE="-bindist", see: https://forums.gentoo.org/viewtopic-p-7916882.html Package-Manager: portage-2.3.0
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.7.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 4d0bfc049f63..a8fcc48f5323 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.0.4.tar.gz 707036 SHA256 ca1bc6a8049f4dfc1d8b2d3ed3a850ea24c8b09445c53d30db9ccbf9dfcfdc49 SHA512 069ec359860b941ce18adb5883b80f75fba017367ea5901a10f08466788cde46aab019e9b275a9524b623a7e34de957e4087ebd891d3aee9cad55a5c1a47f95b WHIRLPOOL 4b4852bb162dd83fbd3ca809553122e105518decd3d2c2d870f23b0369238502e253ba232964dbc3ba0e174f9c8ff43be5abfb47f2b5214a6629e895242f4a1d
DIST airdcpp-webclient-1.0.6.tar.gz 707741 SHA256 10d1303d23341411cab61981c7185fb962a00bec59e2273d08c2c6fe51601411 SHA512 d80f0640a16b2f98f1a193553bbb67763cb327b7db40757bca9368c1fe6a053ef897566db1b7ad4583a438db4e772f2e0cc85c1f795f453109a4ab5d52234350 WHIRLPOOL e1923723377c879958fd4410b03eb1b4ea1e18a468b485c609e4d7fd98479d6a26b958afcd21463913a846c2e3b53634da18aa20d50c08e308865aeedac50362
+DIST airdcpp-webclient-1.0.7.tar.gz 717747 SHA256 a98a7a478a99334ddb2ed91eef888cec2ee71601d894d16f100b35e7849f0265 SHA512 15501fa6e7f48241f27b2bbffb977731fe2fb35043ddd6d15575ba5fe29271548093098298a82c67d8f0b32a3194b5a14f1197053c39199612aebc1ab296e0c2 WHIRLPOOL 118ec35af049fdb6ffb24fcf97e1c9e47e6b9e66399dcc83a7137b5a3a8257b3015039f13d690e52d3dac3cacc7c450d6ff5cc13b4d55440a27b7c8b9de3c9cb
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.7.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.7.ebuild
new file mode 100644
index 000000000000..0fa03c344da9
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ dev-lang/python:*
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_setup() {
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}