summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-02-09 00:58:41 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-02-09 00:58:44 +0100
commit9803d7f8eb348d93eaf0e484516a323e53741391 (patch)
tree3ac1087bc153ddfa72913a571749c701655df4d9 /net-p2p/airdcpp-webclient
parentnet-misc/ipv6calc: version bump to 2.0.0 (diff)
downloadgentoo-9803d7f8eb348d93eaf0e484516a323e53741391.tar.gz
gentoo-9803d7f8eb348d93eaf0e484516a323e53741391.tar.bz2
gentoo-9803d7f8eb348d93eaf0e484516a323e53741391.zip
net-p2p/airdcpp-webclient: bump to 2.5.1, EAPI=7
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index beb8b3597a26..f20a307dd746 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-2.4.0.tar.gz 899040 BLAKE2B a498624fb273ecc756c6d1ce9fc6ebc4b44e0e6788ae41208a308d9e204a4657503e9123c7ed41c9a5d1ffca6a1eda54a3fdddb609244cea54b41605927281d9 SHA512 6598fd6bebae65381dd97763da4a69ce32e4d3f5cb16e5cbd66bd29d973e36c3a616138c84426c462cfd275b39b8d4bd4c0162de9dba3c02b603735ad842a3a7
DIST airdcpp-webclient-2.5.0.tar.gz 900078 BLAKE2B 53f5e096a3a6cc7c77c92bef32a7aaf0fb7b5e49740718252c7b4e233b80c52ca27029ba24fef4f1ab9c4c360da182accffb8ba7de27ef9b0b4aaa011005b689 SHA512 cf0220e3f2096304e393a4bd833e81c1427dbd144a56498712c9e18f2ec14f35d9112ad0ff05f54aad5a57126d68fc46c2bf20806dd7464a5bdb301543b08809
+DIST airdcpp-webclient-2.5.1.tar.gz 898980 BLAKE2B a930a13d34068977d0184ea56163cb9ae0f47bd92cfb724145f287742fb034ebc89f0a55fc5b07a8761de0749d3725912d4f4682542ac60c93b003a08ed24c9f SHA512 297aa780ecc35f48000eba1cc3b6f284a64954fbcc257ed58c84f2c88901b1c01c17228883c6569fa1333f0e41067f9fe7623ef24e458844544f6d6cc2b45c4c
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.1.ebuild
new file mode 100644
index 000000000000..6e5120d6044e
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}