summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 12:19:09 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 12:21:41 -0500
commit6fdd55bee7111a461bd22ef414b0efa9e5c59ef7 (patch)
tree3a49086946bc224647005cf524cd7a1b392a46c6 /net-p2p/amule
parentnet-p2p/amule: use #!/sbin/openrc-run instead of #!/sbin/runscript (diff)
downloadgentoo-6fdd55bee7111a461bd22ef414b0efa9e5c59ef7.tar.gz
gentoo-6fdd55bee7111a461bd22ef414b0efa9e5c59ef7.tar.bz2
gentoo-6fdd55bee7111a461bd22ef414b0efa9e5c59ef7.zip
net-p2p/amule: remove old version
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/amule-2.3.1-r1.ebuild107
1 files changed, 0 insertions, 107 deletions
diff --git a/net-p2p/amule/amule-2.3.1-r1.ebuild b/net-p2p/amule/amule-2.3.1-r1.ebuild
deleted file mode 100644
index 565019e13b02..000000000000
--- a/net-p2p/amule/amule-2.3.1-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils wxwidgets user
-
-MY_P=${PN/m/M}-${PV}
-S="${WORKDIR}"/${MY_P}
-
-DESCRIPTION="aMule, the all-platform eMule p2p client"
-HOMEPAGE="http://www.amule.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="daemon debug geoip nls remote stats unicode upnp +X"
-
-DEPEND=">=dev-libs/crypto++-5
- sys-libs/binutils-libs:0=
- >=sys-libs/zlib-1.2.1
- >=x11-libs/wxGTK-2.8.12:2.8[X?]
- stats? ( >=media-libs/gd-2.0.26:=[jpeg] )
- geoip? ( dev-libs/geoip )
- upnp? ( >=net-libs/libupnp-1.6.6 )
- remote? ( >=media-libs/libpng-1.2.0:0=
- unicode? ( >=media-libs/gd-2.0.26:= ) )
- !net-p2p/imule"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use stats && ! use X; then
- einfo "Note: You would need both the X and stats USE flags"
- einfo "to compile aMule Statistics GUI."
- einfo "I will now compile console versions only."
- fi
-}
-
-pkg_preinst() {
- if use daemon || use remote; then
- enewgroup p2p
- enewuser p2p -1 -1 /home/p2p p2p
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.2.6-fallocate.diff
- # Bug 412371
- epatch "${FILESDIR}"/${PN}-2.3.1-gcc47.patch
-}
-
-src_configure() {
- local myconf
-
- WX_GTK_VER="2.8"
-
- if use X; then
- einfo "wxGTK with X support will be used"
- need-wxwidgets unicode
- else
- einfo "wxGTK without X support will be used"
- need-wxwidgets base-unicode
- fi
-
- if use X ; then
- use stats && myconf="${myconf}
- --enable-wxcas
- --enable-alc"
- use remote && myconf="${myconf}
- --enable-amule-gui"
- else
- myconf="
- --disable-monolithic
- --disable-amule-gui
- --disable-wxcas
- --disable-alc"
- fi
-
- econf \
- --with-denoise-level=0 \
- --with-wx-config="${WX_CONFIG}" \
- --enable-amulecmd \
- $(use_enable debug) \
- $(use_enable daemon amule-daemon) \
- $(use_enable geoip) \
- $(use_enable nls) \
- $(use_enable remote webserver) \
- $(use_enable stats cas) \
- $(use_enable stats alcc) \
- $(use_enable upnp) \
- ${myconf}
-}
-
-src_install() {
- default
-
- if use daemon; then
- newconfd "${FILESDIR}"/amuled.confd amuled
- newinitd "${FILESDIR}"/amuled.initd amuled
- fi
- if use remote; then
- newconfd "${FILESDIR}"/amuleweb.confd amuleweb
- newinitd "${FILESDIR}"/amuleweb.initd amuleweb
- fi
-}