summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-04-15 23:58:34 +0300
committerMichał Górny <mgorny@gentoo.org>2019-04-22 09:26:32 +0200
commite8dc99ed1e5f679d13ff5ecd1926bbb23d6a7dea (patch)
treea6bd935d6912a8597a84eddf0cfbaf41551287bf /net-p2p/amule
parentnet-p2p/amule: revbump for wxGTK:3.0-gtk3 (diff)
downloadgentoo-e8dc99ed1e5f679d13ff5ecd1926bbb23d6a7dea.tar.gz
gentoo-e8dc99ed1e5f679d13ff5ecd1926bbb23d6a7dea.tar.bz2
gentoo-e8dc99ed1e5f679d13ff5ecd1926bbb23d6a7dea.zip
net-p2p/amule: remove old and broken
Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11702 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/amule-2.3.2-r1.ebuild104
-rw-r--r--net-p2p/amule/files/amule-2.2.6-fallocate.diff23
2 files changed, 0 insertions, 127 deletions
diff --git a/net-p2p/amule/amule-2.3.2-r1.ebuild b/net-p2p/amule/amule-2.3.2-r1.ebuild
deleted file mode 100644
index 51bb5d2472b5..000000000000
--- a/net-p2p/amule/amule-2.3.2-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-WX_GTK_VER="3.0"
-
-inherit wxwidgets user
-
-MY_P="${PN/m/M}-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="aMule, the all-platform eMule p2p client"
-HOMEPAGE="http://www.amule.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ppc ppc64 ~sparc x86"
-IUSE="daemon debug geoip nls remote stats unicode upnp +X"
-
-COMMON_DEPEND="
- dev-libs/crypto++
- sys-libs/binutils-libs:0=
- sys-libs/zlib
- x11-libs/wxGTK:${WX_GTK_VER}[X?]
- stats? ( media-libs/gd:=[jpeg,png] )
- geoip? ( dev-libs/geoip )
- upnp? ( net-libs/libupnp:* )
- remote? ( media-libs/libpng:0=
- unicode? ( media-libs/gd:= ) )
- !net-p2p/imule"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-2.2.6-fallocate.diff" )
-
-pkg_setup() {
- if use stats && ! use X; then
- einfo "Note: You would need both the X and stats USE flags"
- einfo "to compile aMule Statistics GUI."
- einfo "I will now compile console versions only."
- fi
-}
-
-pkg_preinst() {
- if use daemon || use remote; then
- enewgroup p2p
- enewuser p2p -1 -1 /home/p2p p2p
- fi
-}
-
-src_configure() {
- local myconf
-
- if use X; then
- einfo "wxGTK with X support will be used"
- need-wxwidgets unicode
- else
- einfo "wxGTK without X support will be used"
- need-wxwidgets base-unicode
- fi
-
- if use X ; then
- use stats && myconf="${myconf}
- --enable-wxcas
- --enable-alc"
- use remote && myconf="${myconf}
- --enable-amule-gui"
- else
- myconf="
- --disable-monolithic
- --disable-amule-gui
- --disable-wxcas
- --disable-alc"
- fi
-
- econf \
- --with-denoise-level=0 \
- --with-wx-config="${WX_CONFIG}" \
- --enable-amulecmd \
- --without-boost \
- $(use_enable debug) \
- $(use_enable daemon amule-daemon) \
- $(use_enable geoip) \
- $(use_enable nls) \
- $(use_enable remote webserver) \
- $(use_enable stats cas) \
- $(use_enable stats alcc) \
- $(use_enable upnp) \
- ${myconf}
-}
-
-src_install() {
- default
-
- if use daemon; then
- newconfd "${FILESDIR}"/amuled.confd amuled
- newinitd "${FILESDIR}"/amuled.initd amuled
- fi
- if use remote; then
- newconfd "${FILESDIR}"/amuleweb.confd amuleweb
- newinitd "${FILESDIR}"/amuleweb.initd amuleweb
- fi
-}
diff --git a/net-p2p/amule/files/amule-2.2.6-fallocate.diff b/net-p2p/amule/files/amule-2.2.6-fallocate.diff
deleted file mode 100644
index 8d1485a67786..000000000000
--- a/net-p2p/amule/files/amule-2.2.6-fallocate.diff
+++ /dev/null
@@ -1,23 +0,0 @@
-Disable fallocate #562992
-
-This is only a workaround to fix FTBFS, the configure check is wrong and needs to be fixed:
-http://www.amule.org/abugs/view.php?id=1572
-
---- a/src/ThreadTasks.cpp
-+++ b/src/ThreadTasks.cpp
-@@ -506,6 +506,15 @@ void CCompletionTask::OnExit()
- #include <stdlib.h>
- #include <errno.h>
-
-+// #562992
-+#if defined(__alpha__) || defined(__hppa__)
-+#undef HAVE_FALLOCATE
-+#endif
-+
-+#if defined(__hppa__)
-+#undef HAVE_SYS_FALLOCATE
-+#endif
-+
- CAllocateFileTask::CAllocateFileTask(CPartFile *file, bool pause)
- // GetPrintable is used to improve the readability of the log.
- : CThreadTask(wxT("Allocating"), file->GetFullName().RemoveExt().GetPrintable(), ETP_High),