summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-03-11 13:32:10 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-03-11 13:33:09 -0500
commit5c9f382694ab27951a2c8fbe62b63274d11f468a (patch)
treeb65bcc87483d151a7a581adf6f6bd0af920b860c /net-p2p/bitcoin-qt
parentnet-p2p/bitcoin-cli: add knots support (diff)
downloadgentoo-5c9f382694ab27951a2c8fbe62b63274d11f468a.tar.gz
gentoo-5c9f382694ab27951a2c8fbe62b63274d11f468a.tar.bz2
gentoo-5c9f382694ab27951a2c8fbe62b63274d11f468a.zip
net-p2p/bitcoin-qt: add knots support
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-p2p/bitcoin-qt')
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.13.2.ebuild14
-rw-r--r--net-p2p/bitcoin-qt/metadata.xml1
2 files changed, 8 insertions, 7 deletions
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.13.2.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.13.2.ebuild
index e87a052d89ac..e99ea9dae1e1 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.13.2.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.13.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2010-2016 Gentoo Foundation
+# Copyright 2010-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
BITCOINCORE_COMMITHASH="0d719145b018e28d48d35c2646a5962b87c60436"
BITCOINCORE_LJR_DATE="20170102"
-BITCOINCORE_IUSE="dbus kde +libevent ljr +qrcode qt5 +http test +tor upnp +wallet zeromq"
+BITCOINCORE_IUSE="dbus kde +libevent knots +qrcode qt5 +http test +tor upnp +wallet zeromq"
BITCOINCORE_POLICY_PATCHES="+rbf spamfilter"
LANGS="af af_ZA ar be_BY bg bg_BG ca ca@valencia ca_ES cs cs_CZ cy da de el el_GR en en_GB eo es es_AR es_CL es_CO es_DO es_ES es_MX es_UY es_VE et et_EE eu_ES fa fa_IR fi fr fr_CA fr_FR gl he hi_IN hr hu id_ID it it_IT ja ka kk_KZ ko_KR ku_IQ ky la lt lv_LV mk_MK mn ms_MY nb ne nl nl_NL pam pl pt_BR pt_PT ro ro_RO ru ru_RU sk sl_SI sq sr sr@latin sv ta th_TH tr tr_TR uk ur_PK uz@Cyrl vi vi_VN zh zh_CN zh_HK zh_TW"
KNOTS_LANGS="et_EE nl_NL"
@@ -32,18 +32,18 @@ RDEPEND="
"
DEPEND="${RDEPEND}
qt5? ( dev-qt/linguist-tools:5 )
- ljr? (
+ knots? (
gnome-base/librsvg
media-gfx/imagemagick[png]
)
"
REQUIRED_USE="
http? ( libevent ) tor? ( libevent ) libevent? ( http tor )
- !libevent? ( ljr )
+ !libevent? ( knots )
"
for lang in ${KNOTS_LANGS}; do
- REQUIRED_USE="${REQUIRED_USE} linguas_${lang}? ( ljr )"
+ REQUIRED_USE="${REQUIRED_USE} linguas_${lang}? ( knots )"
done
src_prepare() {
@@ -53,7 +53,7 @@ src_prepare() {
for lan in $LANGS; do
if [ ! -e src/qt/locale/bitcoin_$lan.ts ]; then
- if has $lan $KNOTS_LANGS && ! use ljr; then
+ if has $lan $KNOTS_LANGS && ! use knots; then
# Expected
continue
fi
@@ -94,7 +94,7 @@ src_install() {
bitcoincore_src_install
insinto /usr/share/pixmaps
- if use ljr; then
+ if use knots; then
newins "src/qt/res/rendered_icons/bitcoin.ico" "${PN}.ico"
else
newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
diff --git a/net-p2p/bitcoin-qt/metadata.xml b/net-p2p/bitcoin-qt/metadata.xml
index 795294847bad..0c64d432c74c 100644
--- a/net-p2p/bitcoin-qt/metadata.xml
+++ b/net-p2p/bitcoin-qt/metadata.xml
@@ -13,6 +13,7 @@
<flag name="bitcoin_policy_rbf">Replace By Fee policy: Your node will preferentially mine and relay transactions paying the highest fee, regardless of receive order</flag>
<flag name="bitcoin_policy_spamfilter">Enhanced spam filter policy: Notorious spammers will not be assisted by your node</flag>
<flag name="http">Enable support for the JSON-RPC and REST HTTP server (builtin net-p2p/bitcoind)</flag>
+ <flag name="knots">Build enhanced Bitcoin Knots version, rather than Bitcoin Core</flag>
<flag name="libevent">Use dev-libs/libevent</flag>
<flag name="ljr">Enable Luke Dashjr's patches</flag>
<flag name="qrcode">Enable generation of QR Codes for receiving payments</flag>